Failed to update jupyter. Now also yunohost-api is down and can't access to web UI

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.0.10.2
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no and yes
If yes, please explain:
downgraded libsodium23 to 1.0.18-1

Description of my issue

So everything started when I tried to update jupyterhub 3.4.3 → to 3.5.0. After that the whole app disappeared from the list. When I went to see the problem from the logs, I saw this https://paste.yunohost.org/raw/tijifoqenu

Then I went chat room to ask some help.
Then I got advise to try this:

sudo apt install libsodium23=1.0.18-1

And it went ok. Then I tried to restore the app from the log window “restore app from backup” but it didn’t do anything. No new logs, nothing.

Then I tried to restore app different way from web UI: Backups->local->restore jupyter upgrade 2 days ago. It did start and finished it also. Now I see the jupyter as app, but I can’t access to it. The webpage just says “Bad Gateway by nginx”. Here are the new logs: https://paste.yunohost.org/raw/bidigibema
I restarted the server multiple times. Then on the chat, they advised to install jupyterlab manually, because it looks like it did not install correctly.
I tried to install jupyterhub with this command:

sudo pip3 install jupyterhub

It did install it, but didn’t help, it actually went to worse: now in the admin UI I get error message that yunohost-api is down.
I went to see with ssh, is yunohost-api running and I got this message:

admin@yuno:~$ systemctl status yunohost-api
● yunohost-api.service - YunoHost API Server
     Loaded: loaded (/etc/systemd/system/yunohost-api.service; enabled; vendor >
     Active: activating (auto-restart) (Result: exit-code) since Mon 2022-11-14>
    Process: 2656 ExecStart=/usr/bin/yunohost-api (code=exited, status=1/FAILUR>
   Main PID: 2656 (code=exited, status=1/FAILURE)
        CPU: 122ms

And now I don’t know what to do. Any good advises?

I got the api fix ( sudo pip3 install --upgrade gevent), but can’t install new juypyter. It tries to find folder “.venv/bin/jupyterhub” but it doesn’t exists. Even if I install it, jupyterhub, manually (it says it is already installed)

Got it work. Had to latest migration. result: Error on updateting from 3.4.3~ynh1 to 3.5.0~ynh1 · Issue #123 · YunoHost-Apps/jupyterlab_ynh · GitHub