Failed synapse upgrade

My YunoHost server

Hardware: VPS bought online
YunoHost version: 4.3.3, recently upgraded
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Today I upgraded Yunohost to 4.3.3 and then proceeded to upgrade Synapse.

The upgrade failed and I can’t restore the app due to some leftover permissions in the database.

Here’s the log: https://paste.yunohost.org/raw/ipexosasic

The problem seems to have started with The operation 'Create permission 'synapse'' could not be completed. And now during attempts at restoring it says Permission 'synapse.main' already exists

Ok, running

yunohost tools shell -c "from yunohost.permission import permission_delete; permission_delete('synapse.main', force=True)"

is getting me somewhere

I ran the above command, backed up Element, uninstalled Element, restored Synapse, restored Element and now it works

1 Like