Error while updating gogs

,

My YunoHost server

Hardware: Raspberry Pi 4 at home
YunoHost version: 4.3.4.1
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I’mm trying to update gogs with this command:

sudo yunohost app upgrade gogs

I’m getting this error :

Info: WARNING - mkdir: cannot create directory ‘’: No such file or directory

The full log is available here:
https://paste.yunohost.org/raw/eticijogos

Do you know what could be the issue ?

I don’t have Gogs installed, so no upgrade, but had no problem (log) installing the app.

I did notice in your log


2022-02-07 20:04:04,813: DEBUG - 87183 The permission database has been resynchronized
2022-02-07 20:04:05,331: DEBUG - 87702 SSOwat configuration regenerated
2022-02-07 20:04:05,370: DEBUG - 87740 Loading migration 0016_php70_to_php73_pools...
2022-02-07 20:04:05,372: DEBUG - 87743 Loading migration 0015_migrate_to_buster...
2022-02-07 20:04:05,374: DEBUG - 87745 Loading migration 0020_ssh_sftp_permissions...
2022-02-07 20:04:05,376: DEBUG - 87747 Loading migration 0018_xtable_to_nftable...
2022-02-07 20:04:05,378: DEBUG - 87748 Loading migration 0017_postgresql_9p6_to_11...
2022-02-07 20:04:05,379: DEBUG - 87749 Loading migration 0019_extend_permissions_features...
2022-02-07 20:04:05,435: DEBUG - 87803 Restoring the app 'gogs'...

Mine: yunohost_version: 4.3.6.2

It might just make the difference if you upgrade your Yunohost system before upgrading the apps.

Thanks for your reply

I tried with 4.3.6.2 and still have the same issue : https://paste.yunohost.org/raw/mikinegoje

Please read this :

1 Like

Thank you very much, it solved my issue !

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.