Error while updating apps, 2nd attempt


First, my apologies to Aleks for not following the guide in my earlier post; Error while updating send.
This topic is a correction of the one above, since the issue happens with every update of all apps.

Hardware: AMD64
YunoHost version: (stable).
I have access to my server : Yes
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: it’s behind a VPN exactly like: Homemade WireGuard VPN on a VPS server


If I want to update any app I get this error:

/usr/share/yunohost/helpers.d/apt: regel 400: syntaxfout nabij onverwacht symbool 'do'
/usr/share/yunohost/helpers.d/apt: regel 400: ` do'
250 /usr/share/yunohost/helpers.d/apt: regel 400: syntaxfout nabij onverwacht symbool 'do'
251 /usr/share/yunohost/helpers.d/apt: regel 400: ` do'

In Dutch, it says syntax error near unexpected symbol in rule 400: do’.

Edit: Corrected the YH version number to

Now if you could share the full log and not just 4 lines that’d be great … like … as explained in the topic’s template


I will do that later, since a migration is running. Merci!




1 Like

:frowning: I always do my best explaining stuff, sorry that I make you don’t feel like it. But as I told you in my private message, I thought that this would be applicable to more people than only me, that’s why I left out the server description. At this point I just need some time to do other stuff as well and gather the requested information. I did only copy and paste the short part of the log since all other stuff was green and ok, the updated till worked only the described error message popped up. So I did not want you to read all other maybe unnecessary garbage.

I only wanted to help you and the community and this is the response, auwtsj that hurts.
I also want to make it clear to you that I did not ask you to help immediately, since the app update still worked. It seems to be a minor bug, not an urgent one.

Sure, here you go:

Just a small info, you say you use YunoHost but the log say
Maybe there is a problem in this version and you should upgrade to the latest 4.x.x before going to 11.x.x ?

And the logs says that many files were manually modified,even if it might not be the source of the current problem, as you only say you modified things to be behind a vpn, are all these changes linked to this ?


The issue was fixed in


Could be, I only reflect the version number which YH itself tells me that it is on. Which is currently

I changed some PHP values and minor things, the only mature thing I changed is that is behind a VPN. On which I spend hours together with @rungeard and which @Aleks helped me fix it when my networking service couldn’t come up.

Anyhow, since all migrations and updates are done, the issue resolved itself.

Thank you again guys.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.