Error when reinstating deleted domain

My YunoHost server

**Hardware:**Core i3 with 8 GB Ram
YunoHost version: x.x.x
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no - except the domain was deleted previously

I had a subdomain which I removed some time ago.

When I attempted to reinstall it the following error was returned:

Error: You are attempting to overwrite a good and valid certificate for domain! (Use --force to bypass)

There is no --force parameter for

yunohost domain add

I do not know what to do next and would be very grateful for some help.
The log is available at

Thank you if you help me!!!

Well, I solved it by reading this topic:

I removed all certificates related to domain in /ec/yunohost/certs and tried the domain add command and it worked.

1 Like

Thank you! Saved me!

For those who want the short answer:

cd /etc/yunohost/certs
rm -rf*
yunohost domain add

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.