Error when loggin in after 2026.9.* update

I have searched the forum for similar issues

on

This category is for issues regarding specific apps, NOT general issues with YunoHost.

on

This form is written in English but feel free to write in French if you’re more comfortable!

on

What app is this about, and its version

HomeAssistant, 2026.9.*~ynh1

What YunoHost version are you running

12.1.41.2

What type of hardware are you using

Raspberry Pi 3, 4+

Describe your issue

Hello, and thanks for your work on yunohost !

After upgrading from HomeAssistant 2026.8.3~ynh1 to 2026.9.0.~ynh1 or 2026.9.1.~ynh1, trying to log in HomeAssistant gives me a generic error.

Share relevant logs or error messages

I’ve got the exact same problem and I couldn’t find a way to fix it yet.
Any help would be much appreciated.

Update: I found this very recent issue on upstream’s github, which seems to confirm the issue.

I tried applying the workaround reported, which consists of adding args: [] to the provider configuration, and that specific exception doesn’t happen anymore, but the login still fails for some reason.

Bug confirmed, I don’t know for now if it’s upstream bug or upstream feature…
The suggestion here work fine for me, you shold manually edit /home/yunohost.app/homeassistant/configuration.yaml and modfify as follow:
from:

  auth_providers:
    - type: command_line
      command: /home/yunohost.app/homeassistant/bin/ynh_ldap-auth.sh
      meta: true

to:

  auth_providers:
    - type: command_line
      command: /home/yunohost.app/homeassistant/bin/ynh_ldap-auth.sh
      meta: true
      args: []

Thanks for the feedback!
I applied the change in that exact way, but I still get an authentication error when using my yunohost SSO credentials

ERROR (MainThread) [homeassistant.auth.providers.command_line] User '{redacted_username}' failed to authenticate, command exited with code 1

did you restart the service?

yes

Not the same bug, that one looks like a credential or permission issue. You can debug it by activating the DEBUG setting in the command line script /home/yunohost.app/homeassistant/bin/ynh_ldap-auth.sh. It will produce in the same folder ldap-auth.log with all the information.

That works for me, thanks you !

I’ll mark your answer as a solution, even if it’s just a temporary one.