Error upgrading / unable to upgrade: Jupyterlab

Hi Folks,

I have an issue updating JupyterLab on my server. Here are the specs:

Hardware: VPS bought online
YunoHost Version:
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

I’ve been running this install of Yunohost for some time now and the update process worked fine til now. All the other updates did also finish without any hussle even some migrations. Just this upgrade of JupyterLab throws this Error.

Here is the log:

I dont know what to do now… couldn’t find anything on the forums or github…

Can someone point me in the right direction please? ;D

I see this warning in the logs…
Warning: Python 3.7 was not found on your system...

hmm yeah … that could be the issue … but I cant install python3.7

sudo apt install python 3.7 just gives me:

Package python 3.7 is not available, but is referred to by another package…

I also tried to install it through the deadsnakes ppa but didnt succeed…

in the end i just reinstalled jupyterlab wich did the trick ;D

thanks for the help <3

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.