Error setting default domain: "alias <$ALIAS> can not be removed from the 'admins' group"

Greetings, dear fellow creatures

I have just set up my first YunoHost server and encountered error message when trying to (re-) set default domain (DynDNS) after having intermittently set it to a purely local .test domain.

This problem may be somewhat related to Setting default domain fails - where the same error message occured when trying to set a .local domain as default.

My YunoHost server

Hardware: VPS (VIRTUOZZO) from 1blu (
YunoHost version: (stable)
I have access to my server : Through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

I have setup YunoHost on VPS (mentioned above) with free DynDNS entry at TLD In order to change to a different TLD (also with free DynDNS entry), I needed to first create a purely local hostname (as only one free DynDNS entry is supported), then remove the free DynDNS entry and then create the new one.

Trying to set new DynDNS entry as default failed with error message:

error: The alias admins@maindomain.tld can not be removed from the 'admins' group

Complete error log is available at

I would not even consider this error message to be particularly severe - when performing diagnose thru webadmin, everything is reported fine (except for reverse DNS which will still need to be registered by ISP - but this is completely different issue, I guess? :thinking:).

Some more context - most likely mostly irrelevant:

  • If I remember correctly, very similar error message had been issued, when I tried to set the purely local hostname as default (this would be almost exactly same case as described in Setting default domain fails, already mentioned above). However, I ignored this as I was going to delete the local hostname anyway again.
  • I ended up using very same hostname eventually, as I had alreday configured as default in the very first place.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.