Error on synapse install

My YunoHost server

Hardware: Regular computer (64 bits)
YunoHost version: 11.1.15
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen if really necessary
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: I configured apt to use the backport repository to get borgbackup 1.2
If your request is related to an app, specify its name and version: synapse 1.79.0~ynh1

Description of my issue

I just tried to install synapse. I get an the following warning then error when running the installation script :

2023-04-01 00:53:03,729: WARNING - The password needs to be at least 12 characters long and contain a digit, upper, lower and special characters
2023-04-01 00:53:03,731: DEBUG - You are now about to define a new user password. The password should be at least 8 characters long—though it is good practice to use a longer password (i.e. a passphrase) and/or to a variation of characters (uppercase, lowercase, digits and special characters).
2023-04-01 00:53:03,820: DEBUG - + ynh_exit_properly
2023-04-01 00:53:04,326: DEBUG - + ynh_clean_setup
2023-04-01 00:53:04,327: DEBUG - + ynh_clean_check_starting
2023-04-01 00:53:04,327: DEBUG - + '[' -n '' ']'
2023-04-01 00:53:04,328: DEBUG - + '[' -n '' ']'
2023-04-01 00:53:05,333: ERROR - Unable to install synapse: An error occurred inside the app installation script

I don’t know if the password warning is related to the error, but I just want to specify that there is no admin password field on the yunohost synapse installation page. My account, which is the admin account, fill the requirements stated in the warnings.

Here are the complete logs :

Here are the subsequent sub-operations logs :

Thanks for your help :green_heart:

Ok, I found a solution !

I lowered my password strength requirements both for admin and regular user from the higher (lower case, higher case, number, special char, 12 char) to the lower(Require at least 8 char.) and it worked.

Is this an expected behavior, considering all my passwords meet the higher requirement ? Is there a weaker password generated (or worse, hard-coded) in the installation script ?

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.