Error installing YunoHost on VirtualBox

My YunoHost server

Hardware: XigmaNAS - Ornithopter (revision 8458)
YunoHost version: 4.1.8 64bit
I have access to my server : not yet :frowning:
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi all!
I would like to install Yunohost in a VirtualBox inside a XigmaNAS server. I downloaded the OS image and the checksum is correct. I configured the VM host as described on the yunohost website, and the installation process begins. I can choose the language, country and so on. Roughly in the middle of the core system installation it shows an error: the package cannot by unpacked, I can try five more times but then it stops.
I gave to the VM 3 GB of RAM, 2 CPU’s cores, and 16 GB of disk space. The network seems to be set correctly (according to the messages on the screen).
I have tried a couple of times, the first the error was during the unpacking of “passwd” and the second during the “core-utils” (if I remember correctly).
I also tried to install it on my desktop within Parallels and I had no problem, so I guess the OS image is correct.
I wonder if I miss some points during the VM configuration.
Thank you for your help.

Generally when I get different errors in the same conditions, I think about hardware issues. I don’t have a nas server, so I don’t know how to check hardware health in a nas.

Hi jarod5001,
thank you for your answer. It could be an hardware issue, although it seems strange to me because until now I had no problem with the hard disk and the NAS is working regularly, but I can try to install to another hard disk.
The NAS has of course a limited hardware, just CPU, RAM and hard disk, and until now I had no problem, but thank you for the suggestion.

Unfortunately, even changing the hard disk, the error remains, this time (3 attempts) always at the “passwd” package.
Any other suggestion?
Thank you.

Hi Mailmasterc,

Welcome to the forums!

I didn’t know FreeNAS was renamed to XigmaNAS, looks good.

Is it running on regular Intel/AMD hardware? Seeing 3 GB of RAM for the VM, I expect you got more than 4 GB of RAM in total and a 64-bit BSD installation? If it were a 32-bit CPU I’d say the installation can’t start at all though.

That is more than enough, installation runs fine on 512 MB of RAM and a few GB of space (though it won’t hurt).

To exclude those, you could try installing a regular Debian 10 image. Afterwards install Yunohost followingthe ‘Remote server’ installation manual.

Edit: there’s some information on their forum about installing Debian in a jail, comparable to using containers on Linux. You could have a look at bhyve, which is mentioned there as well.

Hi wbk, thank you for your answer.

The XigmaNAS has 8 GB of RAM and an Intel i3 64 bit CPU, so the hardware requirements are met. The XigmaNAS installed is a 64 bit version. I set 3 GB of RAM for the installation just in case, but I can vary it accordingly, of course. The same for the CPU cores and the GB of hard disk, I wanted to stay “safe” under the hardware point of view. :slight_smile:

Good idea to start with Debian, thank you.

Honestly, since I was stuck with yunohost, I tried Freedombox and I managed to install it without a problem. They seem to me quite similar, to be honest I am just playing with the XigmaNAS to see what I can do, so I can try your debian suggestion but if I encounter more problems I just give up and explore the freedombox world. :slight_smile:

Thanks a lot.

1 Like

Peculiar! Maybe Freedombox is at Debian 11, with Yunohost at 10 for the moment. It could make the difference. I never used the Yunohost VM image, so my comments are not so useful in that regard :wink:

Freedombox is also a great project. I’m sure you’ll get a lot out of your homeserver no matter which you install. Good luck!

1 Like

Hi wbk,

thank you for your support. I am not sure the debian version upon freedombox is based, but as long as it works for me, I’m fine. I’m not an expert, I just want to discover some more possibilities. :slight_smile:

1 Like

I played a lot with yunohost in VM.
I remember that installation failed one time when I had set the hard drive to 10 G. So I just deleted that VM and recreated a new one with bigger disk 20G.
I even tried to install it in an android phone but didn’t work.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.