Error installing wordpress on raspbery pi

Hi there,
I’ve tried too install worpress on my raspery pi3 several times, and I receive always the same error…

Warning: Remove the user wordpress

  • ynh_system_user_exists wordpress
  • getent passwd wordpress
  • echo ‘Remove the user wordpress’
  • sudo userdel wordpress
    Success! The SSOwat configuration has been generated
    Error: Installation failed

I search the forum for clues…

and tried several topics but nun of them served my goal.

so… is there any clue for this problem???


Have you tried running apt-get install mailutils ?

yes, and didn’t work.

I don’t no if helps, but the first warning is:
Warning: W: GPG error: jessie-backports InRelease: The following signatures couldn’t be verified because the public key is not available: NO_PUBKEY 8B48AD6246925553 NO_PUBKEY 7638D0442B90D010

Hi @henriques ,

This topic - in french - should helps you :


A priori in your case :

gpg --keyserver --recv-key 8B48AD6246925553
gpg -a --export 8B48AD6246925553 | sudo apt-key add -
gpg --keyserver --recv-key 7638D0442B90D010
gpg -a --export 7638D0442B90D010| sudo apt-key add -

Then update, but in order to NOT do a messy update to stretch for now, you have to check your /etc/apt/sources.list, you should have jessie and NOT stretch in :

sed -i ‘s|stable|jessie|’ /etc/apt/sources.list
sed -i ‘s|stretch|jessie|’ /etc/apt/sources.list
apt-get update && apt-get dist-upgrade && apt-get autoclean && apt-get autoremove


Error for the key continues.
I will make a new download from here:

and make a fresh install guided by this link:

then I report if every fing went right or wrong.

@henriques ,

You can have a look here if you want to reinstall “from scratch” based on Raspian Jessie :
It’s in french but should do the work.


@henriques ,

You should try this before reinstall :
Edit :

sudo apt update # not needed
sudo rpi-update
sudo reboot


well, I installed with no problems phpmyadmin, rainloop and custom webapp. But wordpress didn’t install.
And yes I used all the information you give, the only thing I didn’t do was

but it will be my next challenge.

Hi @henriques ,

Unless time is not on my side for now :frowning: i translated using the previous french page here :
I hope it could helps you even if the proofreading is in progress and the document can be improved :slight_smile:


Thanks ppr,
but the language barrier is not the problem.

The problem is time and the need of taking my keyboard for my kids. :frowning:

@henriques ,

So it will be your real next challenge :slight_smile:
Don’t hesitate to feedback your experience, even quickly.


I there,
I finally did install the wordpress, using the link that you give me.

Every think work good, but in the link there is one link error in “”, I think that the “bolt an italic” part is unnecessarily.

But it works.

Tanks ppr for your help.

Hi @henriques ,

Exactly … it’s fixed :slight_smile:
If my post has solved the problem, please report it as a solution to help the others YunoHosters :wink:


How do I report the solution for this problem, for others to see.

@henriques ,

Theoretically there is a checkbox at the left-bottom of the post to check as a solution.


Done, thanks ppr.