Error installing Let'sEncrypt without open port 80 using DNS _acme challence on domain

Hello to all. I have been trying to install Let’sEncrypt through CertBot on a Rasbperry Zero serving Yunohost, with no luck, as I cannot open port 80 on my modem/router TG858v8.

So I’ve tried installing Let’sEncrypt certificate without using port 80 following this video
The problem is that DNS, never verify TXT record been deployed, so cannot continue with certification.

Is it feasible to use _acme-challenge on a DNS like
Has anyone tried this _acme-challenge certification with success on Yunohost server without opened 80 port? It will be great to give me a hand on, so to complete my installation.

I recently explained to a user of this forum how to add a custom DNS TXT record on
But i don’t find the topic.

The idea is to use the hook system to do it. The hook name is custom_dns_rules

So the script you have to create could be on this path:


The script should return a json like:

echo "{ 'state': 'succeed', 'stdreturn': [{'type': 'TXT', 'name': '', 'value': 'LETSENCYPT_VALUE','ttl': 3600}]}"