Error at OpenProject install


I’m new to Yunohost and decided to switch to it, as I could find all my app in the catalog.
I made some quick test for all of them with dummy url, and now I decided to migrate my apps.

I face a problem with OpenProject, which I could install once for testing purpose. I deleted it, and try to install it again, under its own URL (a subdomain)

My YunoHost server

Hardware: VPS bought online, OVH bare metal
YunoHost version: 11,2,5
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

When I try to install OpenProject, the installer runs fine until it stops and says “Impossible d’installer openproject : Une erreur est survenue dans le script d’installation de l’application”

See the full log here:

I see that the last commit is 1 week old on the github, and there is a pretty good chance that my test was made before this commit, so maybe it’s related to this last update ?

It seems that there is an issue open with a log looking like yours : Install Error (10.5.1~ynh2) · Issue #5 · YunoHost-Apps/openproject_ynh · GitHub

But this is a quite old issue (from what I understand, you did tests recently)

You can try this to install from an older version :

sudo yunohost app install --debug

But this will block any future upgrade, you’ll have to update manually to the main branch one day :

sudo yunohost app upgrade openproject -u --debug

Note : all this is theory, I never did something like this.

Ok, thank you for your reply.
I didn’t checked the issues on the git.

I tried your solution, with a different branch, but it failed also. I didn’t try with older branch.

Instead, I tried again with the gui app install procedure, but I made different changes.

-as the app seems to be quite demanding, I stopped few services useless for the app install process.
-I ran the install with the default options: visible for invited users and kept the language to “en” instead of “fr”.

And this time it worked.

My server being quite powerful, I don’t think stopping few services really helped.
Maybe it’s more a problem of language option or users allowance during the install process

I can’t try to reproduce, as this app can be installed only once.

1 Like