Error: "502" Bad Gateway Action: "GET" /yunohost/api/versions?locale=en after package update

My YunoHost server

Hardware: Raspberry Pi 1B at home
YunoHost version: 4.6.2
**I have access to my server : through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hello, this is my first post here. I have met the YunoHost Team last Week-end in lyon during JDLL. It has motivated me to restart my Yunohost server.
I have used the update tool, there was a lot of package to update (4.6.2 to 4.6.3). Every thing went fine. I waited more than 10 mn after the install, and I have restarted the RPi.

However, now I can no more access to the admin interface. I have the page, I can enter my login / pwd, but then I have a error window poping out, «YunoHost API is not responding» with the additional message:
Error: “502” Bad Gateway
Action: “PUT” /yunohost/api/diagnosis/run?except_if_never_ran_yet
Error message: The YunoHost API is not responding. Maybe ‘yunohost-api’ is down or got restarted?

I can not access the diagnostic tool, and I do not know what to do. I have restarted the RPi and tried again, but always get the same error.

Thanks for your help.

I’m still trying to solve the problem. I succeed to connect to the server via ssh.
I did run the following commands:
systemctl start yunohost-api

I did run a diagnosis:
yunohost diagnosis run which gives the following output:
root@philetjosie:~# yunohost diagnosis run
Success! Everything looks OK for Base system!
Warning: Found 2 item(s) that could be improved for Internet connectivity.
Success! Everything looks OK for DNS records!
Error: Found 8 significant issue(s) related to Ports exposure!
Error: Found 1 significant issue(s) related to Web!
Illegal instruction

With the detailed diagnosis, I noticed that metronome was stopped, I launched it, but still no change, no way to acces the admin webpage. I’m a bit out of solutions to try, if you have any ideas…

I found the solution on the documentation page related to the RP1:

sed -i ‘s/import miniupnpc/#import miniupnpc/g’ /usr/lib/moulinette/yunohost/firewall.py must be run after each upgrade says the documentation, but in that case, it solves the problem after an update (not upgrade). But with this, everything is back on tracks.

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.