Error 403 MY_webapp custom website

Hardware: Old laptop or compute
YunoHost version: (stable).
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue


finished installing my Yunohost server. Used Peertube/RoundCube/PhpMyAdmin and MY_Webapp (for personal website) everything on a subdomain, except the “my webapp”

All Apps “work” (i think) , Roundcube and Phpmyadmin redirect to the login page of the yunohost instance, if you are not logged in, if you are logged, they work normally. They shouldn’t do that, right?.

Peertube “works” with the domain but not with , probably i need to add a WWW CNAME to the DNS, but for the toplevel domain only like this correct?. it displays video an all if accessed with the name without the www, but not if the user input that, same for the other apps.

Big problem is with the my_webapp. i logged on with SSH and uploaded all files, and on PhPmyadmin i imported the old db (changed configs in the files for auth with db) , but if i visit my website (yes, i choose it as a root), it displays error .htaccess file not found, but i see it in Filezilla, and, if i check other files, they are accessible, except the .htaccess.

Since apache is not supported, how should i fix this problem?, i am a total newbie, i just try and try until it works… If you know the answer, explain it to me like a toddler :slight_smile:

PART 2 :slight_smile:

The custom web app is a laravel app, i already moved all the files to the www folder, and imported the old database. the only error i get his “.htaccess file not found”.

website in question is . other subdomains like work perfectly, so, probably is some nginx configuration i need to do?.

on the script’s developer website i found out this, how i should change that, and where should i write it to make everything work? (possibly?)

Nginx Rules

If you are using nginx, you can use these rules. Just replace /domains/ with path to your site directory.


Make sure to point root to “public” subfolder and not main folder where files are uploaded, otherwise site will not work properly.

server {
    listen 80 default_server;
    server_name default;
    root /domains/;

    index index.html index.htm index.php;

    charset utf-8;

    location ^~ /storage/ {

    location / {
        try_files $uri $uri/ /index.php?$query_string;

    location = /favicon.ico { access_log off; log_not_found off; }
    location = /robots.txt  { access_log off; log_not_found off; }

    access_log off;
    error_log  /var/log/nginx/default-error.log error;

    error_page 404 /index.php;

    location ~ \.php$ {
        fastcgi_split_path_info ^(.+\.php)(/.+)$;
        fastcgi_pass unix:/var/run/php5-fpm.sock;
        fastcgi_index index.php;
        include fastcgi_params;

    location ~ /\.ht {
        deny all;

They definitely should do that. That’s the point of the SSO included in YunoHost. :slight_smile: Don’t hesitate to share why it worries you.

YunoHost considers domains and their subdomains independently. So you could definitely have sub.domain.example or www.domain.example point to a different app than domain.example. Indeed you can use a CNAME to handle your needs, or use a Redirect app to redirect users from www to the root.

It’s not impossible that the .htaccess file was not copied through SSH. Check the contents of the directory with ls -la (and check permissions at the same time). Though are you sure the app requires such a file? It seems to be excluding NGINX by design.

And also, to properly help you, don’t hide the âme of the app you are trying to install, if it’s public. We will be able to help you better.

These will clash with YunoHost’s NGINX architecture. Let’s discuss that when you will have given us more info. :slight_smile:

the .htaccess file is in the directory, checked with SSH permissions are correct (i think).
the app name is MTDb - Ultimate Movie&TV Database from codecanyon MTDb - Ultimate Movie&TV Database by Vebto | CodeCanyon
Here the documentation Vebto

I have the app hosted on siteground where it works perfectly, didn’t need to do anything at all. to transfer that to my yunohost i did this : copied all files and uploaded to folder www/my_webapp (the folder the custom webapp created). and for the database, i installed phpmyadmin, then imported it, and added user and privileges. the problem is still the same, .htaccess file not found.

permissions are for folders 755 and files 644

Here the webfiles if someone wants to test things out

Are you sure about the location of the files? The root folder of apps should be /var/www/my_webapp/www/.
You can share screenshots of your SFTP software listing the files, that will be easier to follow. :slight_smile:

Sure of it, here is a screenshot of Putty (SFTP) and Filezilla (SFTP)

As you can see, the .htaccess file is in the directory if i see it with Filezilla, while with Putty is not displayed (why?)

Just to be clear, my_webapp is without db (i manually imported it with phpmyadmin app and created the user with all privileges as the .env file), and i uploaded all files to the www directory, i did not change file permissions or anything else.

ls -la would bring the proper output, including hidden files. :wink: I will be able to have a look later tonight.

Ok, is displayed correctly even on putty (added the screenshot to the link).

At least i am learning new things as a Linux newbie :rofl:

I kinda don’t understand where is the problem. Rn, i will re-upload the script to a subdomain, so my website on siteground can work normally while i keep trying.

My problem didn’t get solved…

I keep getting the messagge .htaccess file not found.

Anyway, while i am trying with the original files, and the error is the same, but, i managed to bring it down to a problem related to nginx configuration. Following this tutorial Vebto i see that i need to edit the nginx configuration files, Which obviously i did not, which path should i input, since i am using the custom web app, and, where are the files located?.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.