Erreur upgrade Piwigo après passage à 3.2


Hier j’ai enfin pris le temps de mettre à jour mon serveur à Stretch+Yunohost 3.2 (j’étais sur Jessie+2.7). Tout s’est bien passé (bravo à tous les gens qui ont bossé sur la migration !).
Suite à cela j’avais 2 apps pouvant être mises à jour dont Piwigo, que je viens de tenter à l’instant. La mise à jour échoue car la sauvegarde pré-mise à jour échoue, apparement parce qu’il manque un fichier de config pour fail2ban. Voir ci-dessous l’erreur reportée.

Une idée de comment résoudre ça ? Merci !

Yesterday I finally took the time to upgrade my server to Stretch+Yunohost 3.2 (it was on Jessie+2.7). Everything went fine (thanks to everyone who worked on the migration!).
Following the upgrade, there were 2 apps that could be upgraded, including Piwigo. I just attempted the upgrade, but it fails because the pre-upgrade backup fails due to a missing config file for fail2ban. See below the reported error.

Anyone has a clue on how to solve this? Thanks!

2018-09-18 21:20:36,964: DEBUG - + sudo BACKUP_CORE_ONLY=1 yunohost backup create --apps piwigo --name piwigo-pre-upgrade2
2018-09-18 21:20:43,081: WARNING - Data dir won’t be saved, because backup_core_only is set.
2018-09-18 21:20:44,287: WARNING - Source path ‘/etc/fail2ban/jail.d/piwigo.conf’ does not exist
2018-09-18 21:20:44,289: WARNING - !!
2018-09-18 21:20:44,290: WARNING - piwigo’s script has encountered an error. Its execution was cancelled.
2018-09-18 21:20:44,292: WARNING - !!
2018-09-18 21:20:44,294: WARNING -
2018-09-18 21:20:44,496: WARNING - Unable to back up the app ‘piwigo’
2018-09-18 21:20:44,497: WARNING - There is nothing to save
2018-09-18 21:20:44,658: ERROR - Unable to upgrade piwigo

This is due to YunoHost 3 migration that implies the deletion of fail2ban configuration files. See this forum post for a workaround/explanation :wink:

1 Like

Thanks for the quick reply!

I first tried the proper but riskier solution (since I had a backup already), but it was a bad idea! Even when disabling pre-upgrade backup, the upgrade failed because of the missing fail2ban files (if I understood correctly the logs). Restoring the backup also failed, because php-fpm was down (because of the failed upgrade), and so all that was left was a half-installed app…

But I was able to clean up things and restore my back-up, create manually the fail2ban files and finally upgrade the app. Phew!

Hi all,

I had the same problem, but none of the Q&D solution or the proper&riskier one worked, and piwigo was uninstalled. I reinstalled it. The data (photos) are expectedly still here (in /home/, I also checked that the data and _upload directories in /var/www/piwigo are correctly symlinked to their counterparts in /home/, but piwigo still does not show anything…

Is there any way to make piwigo aware again of the data in /home/ I tried all the maintenance operations, unsuccessfully…

Do you have a backup of the app? If so, the way I cleaned up the mess was:

  • Make sure php-fpm service is running (systemctl status php7.0-fpm and systemctl start php7.0-fpm)
  • Remove Piwigo (yunohost app remove piwigo)
  • Make sure php-fpm service is still running
  • Restore the piwigo app from your backup (yunohost backup restore $backup-name --apps piwigo)
  • Delete the fail2ban conf files of piwigo, if any

I hope you sort it out!

Thanks a log! Actually, I have used a more radical approach: I uninstalled Piwigo, deleted /home/, reinstalled Piwigo, and uploaded photos again…

By the way, I did not know that the backup could focus on a selected app: thx!

I’ve the same problem.
Obviously, I didn’t have a recent backup.
So, I thought it was the right occasion to set up a periodical backup script.

Unfortunately, the same error occurs when the backup script run, and the backup of piwigo fails.

What can I do ?

the upgrade script can work if I create a dummy file “/etc/fail2ban/jail.d/piwigo.conf”, or it will be create side effects ?