Erreur envoi mail

Matériel: Raspberry Pi à la maison
Version de YunoHost: 4.3.6.3 (stable).
J’ai accès à mon serveur : En SSH | Par la webadmin
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

bonjour …

passons a mon second probleme .
j’utilise yuno depuis tres peu de temps, donc j’ai plein de choses apprendre.

J’utilise rainloop pour gerer de multiples boites mails … et pas de soucis, sauf sur une.
l’addresse locale.

quand j’envoie des mail, ceux ci sont rejetés (du moins par google)

Ils sont rejetés pour le motis suivant :
Our system has
detected that 550-5.7.1 this message does not meet IPv6 sending guidelines
regarding PTR 550-5.7.1 records and authentication.

Je pense que c’est lié a une config de mon reverse DNS …

Dans les diagnostics, j’ai ca :

Le DNS inverse n’est pas correctement configuré en IPv4. Certains emails seront peut-être refusés ou considérés comme des spam

et

Aucun DNS inverse n’est défini pour IPv6. Certains emails seront peut-être refusés ou considérés comme des spam.

Si ca peut aider, je suis chez free, et j’utilise leur reverse DNS

PS : si ca s’avere trop compliqué, c’est pas grave … si c’est pas possible, je laisse tomber l’email local, j’ai d’autre boites

Concernant le reverse DNS chez as-tu tenté de le configurer sur ton espace abonné (dans ma freebox → personnaliser mon reverse DNS) ?

Si tu as de la chance (ca fonctionne pas à tout les coups) ca réglera le problème en IPV4.

Concernant l’IPV6 free ne propose pas (pour le moment) de gérer le reverse DNS.

Une autre solution consiste à utiliser un VPN ou un relais SMTP pour s’affranchir des limites du FAI.

oui, c’est comme ca que je l’ai parametré … par l’interface web free (pas celle de la box).

Alors dans c’est que tu es dans le cas où tu n’as pas de chance et le reverse DNS Free ne marche pas (c’est aléatoire chez Free !).

Chez free, mon reverse DNS ne fonctionne plus malgré que l’option est toujours présente dans l’interface web depuis que free a décidé de faire des modifications sur la ligne et m’a attribué une nouvelle ip.
En désactivant l’ipv6, mes mails sont toujours bien reçu par Gmail. J’avais lu il y a fort longtemps que le reverse dns était nécessaire en ipv6 pour ne pas être rejeter par Google alors que ce n’était pas le cas avec l’ipv4.
Yunohost dispose autrement de l’option smtp.allow_ipv6 à passer sur off que je n’ai jamais testée qui pourrait peut-être aussi fonctionner. A tester, sinon désactiver l’ipv6

comment on fais ca ? desactiver l’ipv6 ? pour le smtp ?

Déjà essaye en utilisant l’option présente dans yunohost et vois si c’est mieux.

yunohost settings set smtp.allow_ipv6 -v False

Si ça ne fonctionne pas, pour désactiver l’ipv6, c’est du domaine de Gnu/Linux et non de yunohost. Tu peux le faire en créant le fichier suivant: /etc/sysctl.d/disableipv6.conf
Et son contenu:

 désactivation de ipv6 pour toutes les interfaces
net.ipv6.conf.all.disable_ipv6=1

# désactivation de l'auto configuration pour toutes les interfaces
net.ipv6.conf.all.autoconf=0

# désactivation de ipv6 pour les nouvelles interfaces (ex:si ajout de carte réseau)
net.ipv6.conf.default.disable_ipv6=1

# désactivation de l'auto configuration pour les nouvelles interfaces
net.ipv6.conf.default.autoconf=0

puis sysctl -p pour prendre en compte les changements.

suite a la sesactivation du smtp sur ipV6, ca as l’air de rouler comme il faut

Par quelle méthode es-tu passé au final? Par l’option de yunohost ou par la désactivation globale d’ipv6 par sysctl?

l’option yunohost … elle semble faire le taf

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.