Erreur d'installation Wallabag : problème avec php7.0-tidy

#1

Bonjour,

J’essaie en vain d’installer Wallabag. Si je comprends bien les logs, le souci se pose au niveau de l’installation du paquet php7.0-tidy :

2019-04-19 15:49:15,335: DEBUG - Dépaquetage de wallabag2-ynh-deps (2.3.2-1) ...
2019-04-19 15:49:15,535: DEBUG - dpkg: wallabag2-ynh-deps : problèmes de dépendances, mais configuration comme demandé :
2019-04-19 15:49:15,535: DEBUG -  wallabag2-ynh-deps dépend de php7.0-tidy ; cependant :
2019-04-19 15:49:15,536: DEBUG -   Le paquet php7.0-tidy n'est pas installé. 

# apt install php7.0-tidy
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
Certains paquets ne peuvent être installés. Ceci peut signifier
que vous avez demandé l'impossible, ou bien, si vous utilisez
la distribution unstable, que certains paquets n'ont pas encore
été créés ou ne sont pas sortis d'Incoming.
L'information suivante devrait vous aider à résoudre la situation :

Les paquets suivants contiennent des dépendances non satisfaites :
php7.0-tidy : Dépend: php7.0-common (= 7.0.33-0+deb9u3) mais 7.0.33-5+0~20190309015553.9+stretch~1.gbp4c6517 devra être installé
E: Impossible de corriger les problèmes, des paquets défectueux sont en mode « garder en l'état ».

Mais je ne sais pas comment résoudre le truc :man_shrugging:t4:

Les logs complets se situent ici.

Merci beaucoup !

#2

Salut,

est-ce que tu peux faire un :

cat /etc/apt/sources.list /etc/apt/sources.list.d/*

et tenter

apt install php7.0-common
#3

Salut et merci pour la réactivité :slight_smile:

# cat /etc/apt/sources.list /etc/apt/sources.list.d/*
#deb http://debian.mirrors.ovh.net/debian/ stretch main
#deb-src http://debian.mirrors.ovh.net/debian/ stretch main

deb http://security.debian.org/ stretch/updates main
deb-src http://security.debian.org/ stretch/updates main

# jessie-updates, previously known as 'volatile'
deb http://debian.mirrors.ovh.net/debian/ stretch-updates main
deb-src http://debian.mirrors.ovh.net/debian/ stretch-updates main

# jessie-backports, previously on backports.debian.org
#deb http://debian.mirrors.ovh.net/debian/ jessie-backports main
#deb-src http://debian.mirrors.ovh.net/debian/ jessie-backports main

deb http://debian.mirrors.ovh.net/debian/ stretch main contrib non-free
deb-src http://debian.mirrors.ovh.net/debian/ stretch main contrib non-free
deb https://deb.nodesource.com/node_6.x stretch main
deb-src https://deb.nodesource.com/node_6.x stretch main
#deb https://packages.sury.org/php/ stretch main
deb http://apt.syncthing.net/ syncthing stable
deb http://forge.yunohost.org/debian/ stretch stable
# apt install php7.0-common
Lecture des listes de paquets... Fait
Construction de l'arbre des dépendances
Lecture des informations d'état... Fait
php7.0-common is already the newest version (7.0.33-5+0~20190309015553.9+stretch~1.gbp4c6517).
php7.0-common passé en « installé manuellement ».
0 mis à jour, 0 nouvellement installés, 0 à enlever et 0 non mis à jour.
#4

Et quid de apt policy php7.0-common ?

#5

Voici :

# apt policy php7.0-common
php7.0-common:
  Installé : 7.0.33-5+0~20190309015553.9+stretch~1.gbp4c6517
  Candidat : 7.0.33-5+0~20190309015553.9+stretch~1.gbp4c6517
 Table de version :
 *** 7.0.33-5+0~20190309015553.9+stretch~1.gbp4c6517 100
        100 /var/lib/dpkg/status
     7.0.33-0+deb9u3 500
        500 http://security.debian.org stretch/updates/main amd64 Packages
     7.0.33-0+deb9u1 500
        500 http://debian.mirrors.ovh.net/debian stretch/main amd64 Packages
#6

Zbleh, ben je ne sais pas d’où sort ta version actuelle de php7.0-common … Est-ce que tu aurais installé / désinstallé des apps cheloues ces derniers temps ?

Sinon je pense que ça devrait résoudre le probleme … :

apt install php7.0-common=7.0.33-0+deb9u3
#7

Hum, à part Monica, je n’ai pas souvenir d’avoir supprimé des apps récemment. Et Monica était en effet chelou et nid à emmerdes :stuck_out_tongue: Je creuse ma mémoire pour déterminer si ça pouvait être autre chose.

J’ai réinstallé la version que tu préconise mais le service php-fpm n’est pas activé, et refuse de l’être :

$ sudo systemctl enable php7.0-fpm
Synchronizing state of php7.0-fpm.service with SysV service script with /lib/systemd/systemd-sysv-install.
Executing: /lib/systemd/systemd-sysv-install enable php7.0-fpm
Failed to enable unit: Unit file /etc/systemd/system/php7.0-fpm.service is masked.
#8

:sweat:

Essaye : systemctl unmask php7.0-fpm

#9

Tout simplement :slight_smile:

Bon, les emmerdes volant en escadrille, je me tape une erreur 502 sur tous mes sites hébergés désormais. Extrait de logs nginx d’un sous-domaine :

 [crit] connect() to unix:/var/run/php/php7.0-fpm-nextcloud.sock failed (2: No such file or directory) [etc.]
#10

Du coup tu as bien relancé php7.0-fpm avec systemctl restart php7.0-fpm ?

#11

Oui oui. Et en désespoir de cause, j’ai même rebooté le serveur…

#12

Et le service est bien running si tu check systemctl status php7.0-fpm ?

#13

Ouaip :

$ sudo systemctl status php7.0-fpm
● php7.0-fpm.service - LSB: starts php7.0-fpm
   Loaded: loaded (/etc/init.d/php7.0-fpm; generated; vendor preset: enabled)
   Active: active (exited) since Fri 2019-04-19 16:50:51 CEST; 41s ago
     Docs: man:systemd-sysv-generator(8)
  Process: 2744 ExecStop=/etc/init.d/php7.0-fpm stop (code=exited, status=0/SUCCESS)
  Process: 2748 ExecStart=/etc/init.d/php7.0-fpm start (code=exited, status=0/SUCCESS)
   CGroup: /system.slice/php7.0-fpm.service

avril 19 16:50:51 ns3313695.ip-5-135-164.eu systemd[1]: Starting LSB: starts php7.0-fpm...
avril 19 16:50:51 ns3313695.ip-5-135-164.eu systemd[1]: Started LSB: starts php7.0-fpm.
#14

ah ou pas ? Je ne sais pas lire ce truc en fait. Ça veut dire quoi “active (exited)” ?

#15

Mouarf pour certain c’est ok que ce soit “exited” mais en l’occurence php7.0-fpm devrait effectivement être active (running) … avec notamment en dessous de “CGroup” une liste avec au moins un “master process” …

Si tu fais un restart ça ne change rien ?

#16

Non ça ne change rien. La commande (sudo systemctl restart php7.0-fpm.service) s’exécute immédiatement, sans râler.

Je ne sais pas si l’info est utile mais les services php7.1-fpm, php7.2-fpm et php7.3-fpm tournent.

#17

Mouarf ben, peut-être que ceci peut résoudre le probleme …

apt install php7.0-fpm --purge --reinstall

(puis re-redémarrer le service)

#18

Ah donc t’as 4 versions de php installées ?

#19

Ok, ça a résolu le 502 !

Désormais, j’ai des soucis avec certaines applications ! Nexcloud me produit une seule page blanche, et Dokuwiki râle en disant que l’authentification a échoué et que l’ACL n’est pas configuré. Y’a une commande à lancer pour remettre tout ça en ordre ?

#20

Uuuuh tu peux remontrer la sortie de systemctl status php7.0-fpm ?