[Epicyon] ActivityPub compliant server

Epicyon is an ActivityPub server implementing S2S and C2S protocols, suitable for single board computers. Includes features such as moderation tools, post expiry, content warnings, and image descriptions.


Hi there, thanks for your work! I didn’t know this soft before your announcement.

It may sound promising, so I wanted to try; but I can’t figure how it work: there was no reported error during the installation, but once on the login page… neither my usual login + the password I gave for installation, nor any other login/password I thought about were working.
All I got while trying to connect is going back to the login page without any error message; or sometimes it get me to a page saying nothing but



Ce n’est rien de moins qu’un triomphe absolu

which, I guess, is some kind of mocking failpage. Am I the one doing something wrong here? The readme didn’t mention how the app should be used/configured rather than via the web interface.

Yes Indeed there is a login problem. Look the issue here:

I talked to the maintainer about this issue. But it was taking time to debug.
Surprisingly when I first installed the app it worked. I think I opened it on a fresh install of brave(so there may be a cookie issue that did not came on freshly installed brave).
I will try to resolve this. Give me little time.

Meanwhile you can choose some other alternatives.

Oh, yeah, I didn’t saw the issue on github, sorry. I tried the python command given there, but it answers that the account doesn’t exist, and it looks like there’s no option to list the existing accounts to figure out why (or did I miss some lines in the help message?)

I’m aware of the existence of other fediverse app. In fact, I was precisely trying to figure out which one would be the best for me when you published your announcement, so I decided to try this one too before choosing (the “no javascript” part was clearly interesting). But there’s no rush here anyway, both the fediverse and me can survive a little more time without each other ^^

So take your time, Courage !, and thanks again for the great work :wink:

1 Like

I’ve been meaning to give Epicyon a try for a while.

Thanks for your work on getting it into YunoHost!

1 Like

Hi there!

Any news?

I really want to try Epicyon, as it seems to be the only available fediverse app that doesn’t “make everything, including coffee”… but for now, it looks like it doesn’t make anything at all.

I just tried a fresh install yesterday. It looks like there’s no login button anymore, and when trying to force login, it just goes back to the login form without any change, so that’s really weird.
I tried the command line: apparently, my account wasn’t created during installation. I did create it manually with the appropriate command, but it doesn’t change anything through web.

I don’t know exactly how I could help trying to solve the issue, but I’m willing to try if you’ve got any idea :slight_smile:

(Alternatively, if you know any other easily installable app that just provides a public page to show my toots and a private form to get messages from mastodon/peertube and reply to them, without chats, calendars, coffee-making and javascript overdose, I’d be glad to try this one too)

1 Like

Will check it this weekend. I gave up last time because it was taking too much time to get fixed.


I also wanted to try this minimalist alternative and encountered the same issue, last github issue about this bug from 21.7.2021, so this app seems to be a non-working one, maybe even dead?

I will try to fix it again. But it can take time. You have alternates to use, please use them. App packaging is not one way process. It needs support from software developers and time to bring these changes in the package.

1 Like

OK; I understand, then it might be a good idea to change the status from working to non-working?

1 Like

Any news on this app?
The app is still flagged as working app.(and fell for it) :smile:

OK. Working for me.

It would not work properly with a subdomain (ie epicyon.yourdomain.com.) When I pointed a fresh domain name at my IP and reinstalled, it just worked.

Also … clear your cache if things are not working and if you are using Brave, you need to turn off the shields.