Encore "Setting up deb package sources failed"

Bonjour,

J’ai installé un yunohost sur une Jessie pour tester, et j’ai bien eut envie de la passer en “prod” (perso hein ^^) sur mon proxmox 4.

Je créé un containeur (CT) sur un template debian Jessie que je met à jour (apt update et apt upgrade) puis j’installe la base de la base selon moi :
apt install tmux git curl zsh tree htop
enfin je lance le install_script trouvé sur le github YunoHost

Mais voilà, j’ai cette erreur :

Setting up deb package sources failed

Et les logs me donnent ça :

Setting up libx11-xcb1:amd64 (2:1.6.2-3+deb8u1) …
Setting up libxtst6:amd64 (2:1.2.2-1+deb8u1) …
Setting up libxv1:amd64 (2:1.0.10-1+deb8u1) …
Setting up openssh-client (1:6.7p1-5+deb8u4) …
Setting up openssh-sftp-server (1:6.7p1-5+deb8u4) …
Setting up openssh-server (1:6.7p1-5+deb8u4) …
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
[ ok ] Restarting OpenBSD Secure Shell server: sshd.
Setting up ssh (1:6.7p1-5+deb8u4) …
Setting up vim-common (2:7.4.488-7+deb8u3) …
Setting up vim-tiny (2:7.4.488-7+deb8u3) …
Setting up wget (1.16-1+deb8u4) …
Setting up libisc95 (1:9.9.5.dfsg-9+deb8u15) …
Setting up libdns100 (1:9.9.5.dfsg-9+deb8u15) …
Setting up libisccc90 (1:9.9.5.dfsg-9+deb8u15) …
Setting up libisccfg90 (1:9.9.5.dfsg-9+deb8u15) …
Setting up libbind9-90 (1:9.9.5.dfsg-9+deb8u15) …
Setting up liblwres90 (1:9.9.5.dfsg-9+deb8u15) …
Setting up bind9-host (1:9.9.5.dfsg-9+deb8u15) …
Setting up dnsutils (1:9.9.5.dfsg-9+deb8u15) …
Setting up krb5-locales (1.12.1+dfsg-19+deb8u4) …
Setting up locales (2.19-18+deb8u10) …
Generating locales (this might take a while)…
Generation complete.
Setting up ncurses-term (5.9+20140913-1+deb8u2) …
Setting up procmail (3.22-24+deb8u1) …
Setting up w3m (0.5.3-19+deb8u2) …
Setting up libxml-libxml-perl (2.0116+dfsg-1+deb8u2) …
update-perl-sax-parsers: Registering Perl SAX parser XML::LibXML::SAX::Parser with priority 50…
update-perl-sax-parsers: Registering Perl SAX parser XML::LibXML::SAX with priority 50…
update-perl-sax-parsers: Updating overall Perl SAX parser modules info file…
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
/bin/bash: warning: setlocale: LC_ALL: cannot change locale (en_US.UTF-8)
Replacing config file /etc/perl/XML/SAX/ParserDetails.ini with new version
Setting up openssl (1.0.1t-1+deb8u7) …
Setting up postfix (2.11.3-1+deb8u2) …
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory

Postfix configuration was untouched. If you need to make changes, edit
/etc/postfix/main.cf (and others) as needed. To view Postfix configuration
values, see postconf(1).

After modifying main.cf, be sure to run ‘/etc/init.d/postfix reload’.

Running newaliases
[ ok ] Stopping Postfix Mail Transport Agent: postfix.
[ ok ] Starting Postfix Mail Transport Agent: postfix.
Processing triggers for libc-bin (2.19-18+deb8u10) …
[ 2018-01-28 16:51:27+00:00 ] ----- [ entering installscript_dependencies ]
Reading package lists…
Building dependency tree…
Reading state information…
dialog is already the newest version.
whiptail is already the newest version.
wget is already the newest version.
Suggested packages:
lsb
The following NEW packages will be installed:
apt-transport-https lsb-release
0 upgraded, 2 newly installed, 0 to remove and 0 not upgraded.
Need to get 164 kB of archives.
After this operation, 294 kB of additional disk space will be used.
Get:1 http : / /ftp debian org/debian/ jessie/main apt-transport-https amd64 1.0.9.8.4 [138 kB]
Get:2 http : / /ftp debian org/debian/ jessie/main lsb-release all 4.1+Debian13+nmu1 [26.5 kB]
Can’t set locale; make sure $LC_* and $LANG are correct!
perl: warning: Setting locale failed.
perl: warning: Please check that your locale settings:
LANGUAGE = “en_US.UTF-8”,
LC_ALL = “en_US.UTF-8”,
LC_TIME = “fr_FR.UTF-8”,
LC_MONETARY = “fr_FR.UTF-8”,
LC_CTYPE = “en_US.UTF-8”,
LC_ADDRESS = “fr_FR.UTF-8”,
LC_TELEPHONE = “fr_FR.UTF-8”,
LC_NAME = “fr_FR.UTF-8”,
LC_MEASUREMENT = “fr_FR.UTF-8”,
LC_IDENTIFICATION = “fr_FR.UTF-8”,
LC_NUMERIC = “fr_FR.UTF-8”,
LC_PAPER = “fr_FR.UTF-8”,
LANG = "en_US.UTF-8"
are supported and installed on your system.
perl: warning: Falling back to the standard locale (“C”).
locale: Cannot set LC_CTYPE to default locale: No such file or directory
locale: Cannot set LC_MESSAGES to default locale: No such file or directory
locale: Cannot set LC_ALL to default locale: No such file or directory
Fetched 164 kB in 0s (2493 kB/s)
Selecting previously unselected package apt-transport-https.
(Reading database … 21885 files and directories currently installed.)
Preparing to unpack …/apt-transport-https_1.0.9.8.4_amd64.deb …
Unpacking apt-transport-https (1.0.9.8.4) …
Selecting previously unselected package lsb-release.
Preparing to unpack …/lsb-release_4.1+Debian13+nmu1_all.deb …
Unpacking lsb-release (4.1+Debian13+nmu1) …
Processing triggers for man-db (2.7.0.2-5) …
Setting up apt-transport-https (1.0.9.8.4) …
Setting up lsb-release (4.1+Debian13+nmu1) …
[ 2018-01-28 16:51:40+00:00 ] ----- [ entering create_custom_config ]
[ 2018-01-28 16:51:40+00:00 ] ----- [ entering confirm_installation ]
[ 2018-01-28 16:51:41+00:00 ] ----- [ entering setup_package_source ]

Failure !
The following error was caught during Yunohost installation :

Setting up deb package sources failed

Les logs dans /var/log/apt/ ne bronchent pas d’un iota (donc pas d’erreur)

J’ai essayé de suivre la solution ici à savoir :

sudo apt purge bunsen-os-release
Mais le paquet n’est juste pas trouvé :

E: Unable to locate package bunsen-os-release

et en lisant ce que fait le script, je me suis dit que ça venait peut être du repo qui n’était pas “accepté”, j’ai donc essayé de faire
wget -O - http://repo.yunohost.org/debian/yunohost.asc | apt-key add - avant de faire l’installation manuelle.

sans résultat non plus.

Du coup j’ai détruit et recommencé sur des debian 7, 8, 9 (sans réel espoir, et j’avais effectivement pas trop besoin d’en avoir) : toujours le même problème. A se demander si ça ne viens pas du système de conteneur ? mais pourquoi ? comment outrepasser le problème ?

Je vous remercie pour votre aide.

Salut,

benheu je sais pas trop ce qu’est un conteneur CT(?) perso :s … Mais ce qui est sur, c’est que ce script ne marchera que sur Jessie (Debian 8)

Apriori, l’erreur se trouve quelque part ici : https://github.com/YunoHost/install_script/blob/master/install_yunohost#L181-L206

J’ai du mal à voir ce qui peut vraiment planter … soit tu n’est pas sous Jessie ou tu n’as pas systemd, mais dans les deux cas il devrait t’afficher le message correspondant. Soit c’est le wget final qui foire ?

Merci pour ta réponse.

Alors un CT (containeur) sur proxmox 4 et suivant, c’est un containeur LXC (la technologie sur laquelle est basée docker aussi d’ailleurs). En gros c’est une technologie qui permet de faire plusieures VMs en utilisant un même noyau Linux pour économiqer ce qu’une VM n’économise pas

Voir cette image qui résume bien

Donc c’est bien Debian 8 (dans mon containeur, et pour proxmox aussi d’ailleurs)

En revanche, effectivement, je viens d’apprendre que les containeurs Jessie n’intérait pas systemd parce que pas compatible à la base. Mais selon Cette discussion il est possible de le faire quand même

j’ai donc fat
apt-get install aptitude
aptitude update
aptitude install systemd systemd-sysv
reboot
Pourquoi aptitude ? parce que ce genre de “chantier” ça pue les dépendences à la c*n et je trouve qu’aptitude gère mieux la problématique que apt-get ou apt.

Il semble que ça fonctionne. Je reviandrait donner suite selon.

EDIT : ça fonctionne bien semble-t-il !