Email not delivering to Gmail

My YunoHost server

Hardware: VPS bought online
YunoHost version: 11.0.9.14
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

Hi guys,

hope you are doing fine. I have an issue with my emails not being delivered to Gmail? I know this probably has nothing to do with Yunohost but I hope you might have more experience with this. I know Gmail can be a pain with their anti-spam policy but sometimes the email go trough, sometimes not. Sometimes they appear in spam, sometimes not at all…

Any ideas how to solve this? They get delivered to hotmail and to my other domains hosted on Yunohost. Haven’t checked more but I get a 8.9/10 on mail-tester.com and on SpamAssassin I get -1.1 (a score below -5 is considered spam).

Thanks

Hi,
Could you try to send mail only with ipv4 with this setting, it can improve the situation. There’s a setting in yunohost for that:

yunohost settings set smtp.allow_ipv6 -v False

If that doesn’t solve the problem, you can revert with the same command and the setting ‘True’ instead of ‘False’.

1 Like

If you could share the detailed reports we could “check more” than you. :wink:

1 Like

Just tried it. Same result unfortunately. Could you provide maybe an explanation why sending only over ipv4 might help? Thanks

I sent you the test results per private message so I can keep things private lol
Thanks

-0.1	DKIM_SIGNED	Message has a DKIM or DK signature, not necessarily valid
This rule is automatically applied if your email contains a DKIM signature but other positive rules will also be added if your DKIM signature is valid. See immediately below.

-1.274	RDNS_NONE	Delivered to internal network by a host with no rDNS
This may indicate you do not have a rDNS configured for your hostname or the rDNS does not match your sending IP

Please correctly set up your DNS and reverse DNS records: DNS zone configuration | Yunohost Documentation, especially the mail-related ones (SPF and DKIM). The DKIM key can be found in the Domains menu of the webadmin.

Edit: It looks like the DKIM is correct actually. :wink: Remains the rDNS.

If your server is assigned an IPv6 block below /64 in CIDR notation (e.g. OVH only gives VPS a unique /128 IPv6), it may get automatically blacklisted. Source.

1 Like

It says that rDNS is okay when I run the Diagnostics. Here’s the result:

The rDNS which I have set inside my VPS Settings is the “main” domain used for YunoHost (which I think the Diagnostics actually recommended when I was run Diagnostics after the initial install). FYI: That “main” domain is different from the ones I’m trying to send emails from… Obviously I can’t set rDNS to the multiple domains I have on my server so that’s a bit confusing. Thanks for your effort

EDIT: Just noticed these pending emails? LOL Those are the ones that got stuck. When I send another one to gmail that number increments, and when I send one that goes through it doesn’t…

EDIT 2: I cleared the queue and sent another test email, then ran mailq in the command line and got this: -Queue ID- --Size-- ----Arrival Time---- -Sender/Recipient------- 798F88000D 682 Thu Sep 15 14:04:57 MYEMAIL@MYDOMAIN.COM (host alt1.gmail-smtp-in.l.google.com[173.194.202.27] said: 550-5.7.25 [MY.IP.ADDR.HERE] The IP address sending this message does not have a 550-5.7.25 PTR record setup, or the corresponding forward DNS entry does not 550-5.7.25 point to the sending IP. As a policy, Gmail does not accept messages 550-5.7.25 from IPs with missing PTR records. Please visit 550-5.7.25 https://support.google.com/mail/answer/81126#ip-practices for more 450 4.7.25 information. t8-20020a170902e84800b00176939b5cd9si3297533plg.578 - gsmtp (in reply to end of DATA command)) RECEIVEREMAIL@GMAIL.COM
Okay, we’re getting somewhere. Will keep updating.

Ugh but that’s puzzling considering your reverse DNS is correctly configured ? x_x Or are PTR records something else ? o_O

1 Like

Yup, according to the provided Google support page:

PTR records are also called Reverse DNS records.

Very confusing, if I figure it out I’ll post here.

I fixed the problem… Had to remove Cloudflare from the main domain and the one I’m trying to send emails from. Now it’s getting a 10/10 from mail-tester.com. I can do without Cloudflare but I like the stuff they offer so will investigate further.

@tituspijean @Aleks @metyun

Glad you fixed it!

Though using Cloudflare would have been an important information to share, especially since the main issue was about DNS. :stuck_out_tongue:

Lol sorry… but as far as I understood Cloudflare doesn’t proxy the email stuff, so based on my limited DNS knowledge I was thinking it’s not relevant.