Email in a non-default domain

,

Hardware: VPS bought online / Old laptop or computer / Raspberry Pi at home / Internet Cube with VPN / Other ARM board / …
YunoHost version: Latest
I have access to my server : Through SSH | through the webadmin | direct access via keyboard / screen | …
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Hello,

I configured Yunohost so that mydomain.tld shows my own website and configured the subdomain portal.mydomain.tld to lets users log in. In order to achieve it I made portal.mydomain.tld the default domain.

I would like to have email accounts at mydomain.tld and only there. So, in the “Domain configuration” of the webadmin I disabled “Outgoing emails” and “Incoming emails” for every subdomain, and keep them enabled for mydomain.tld

In the webadmin, at “Users”, users have a user@mydomain.tld email address and not a user@portal.mydomain.tld

Now I am configuring my email for my myuser@mydomain.tld but the email client complains about the certificate. It says the certificate does not belong to mydomain.tld, but to portal.mydomain.tld. I get the same complaint from mail-tester.com

I have Let’s Encrypt certificates for both mydomain.tld and portal.mydomain.tld

I properly configured the reverse DNS for mydomain.tld, but the diagnosis complains too, it says I should configure it for portal.mydomain.tld

How can I fix this certificate and reverse DNS issues? I would like to have my email at mydomain.tld

Thank you.

Problem easily solved. Apologies for my post, the solution was here:

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.