Efi not detected using yunohost boot

Using a beelink mini s. Trying to duel boot. I created a new partition and even remarked it as efi. I created a boot disk which I had to use an alternative method than on the website because those were flat out not working.

Now it’s not detecting the efi. Which I’ve seen be an issue in the past. I would try to figure out how to just download and install Debian but the problem is that it’s 12. Yunohost needs 11.

I’m very (and I mean verryyyy) new to this. I was trying to do wsl before because I had learned how to wipe all of that every time I messed up.

But that didn’t work at all because that’s where I learned Debian downloads 12 and yunohost is working on 11 and won’t even try.

So I would appreciate any help with the knowledge that the most coding I’ve done in my life is web design. I understand css+ and none of this :rofl:

I have gotten to install starting but no efi detected. Any help would be appreciated. I have googled every form of trying to correct this and my brain hurts.

Hi @LizzieBee, you can download Debian 11 from here: Debian -- Debian “bullseye” Installation Information

Often there is a benefit to downloading the non-free firmware. If you aren’t sure, I would just get it. You can click the amd64 link in the bottom corner for the netinstall of Debian 11 with non-free firmware included.

As for this:

If the first OS in your dual-boot setup is not using an EFI partition already, most likely you will not succeed with setting one up for your second system because the disk will be formatted MBR instead of GPT. If the first system is using an EFI partition, no need to create another one because generally multiple OS’s can share an EFI partition.

What is the other OS on the box? It looks like the Beelink Mini S comes with Windows 11, is that right? In that case I would guess there is already an EFI partition.

Where are you seeing that there is no EFI detected?

Other considerations: make sure secure boot is disabled in the BIOS settings, and the SATA controller is set to AHCI mode (not RAID or anything else). You may also need to disable the “fast startup” feature in Windows, which prevents it from releasing certain system resources when it is supposedly “off”.

1 Like

Adding a few things to what was mentioned in the previous comment. Sorry if you know already but better double check.

  1. PCs have two boot modes: old-style “bios” mode that requires MBR on boot disk, and EFI that requires a GPT partition layout. Machines sold with Windows 10 or 11 have GPT-formatted disks because these OS versions require EFI boot.
  2. PC firmwares can allow either or both boot modes. On modern hardware EFI is recommended.
  3. There are extra EFI options which you can set in BIOS like Fastboot or Secure boot. Fastboot needs to be disabled and Secure boot can be handled by linux installs these days but still makes things a bit more difficult. To check in the firmware settings.
  4. Booting in EFI mode requires efi (boot) files to be in the ESP (EFI System Partition). This is preferably the first partition on the disk, formatted FAT32 and with EFI partition type (code EF00). See screenshot below for my system.
  5. Dual booting can be handled by grub (if installed, for example by Debian) or by other tools like rEFInd which is very flexible and can handle anything EFI, including on different disks, USB, DVDs etc.
    If all of this makes sense then install should work… if you start from a live system, that live system has to boot in the desired mode (most likely EFI) otherwise EFI install will fail…

I did get safe boot disabled and also fast boot disabled. I saw that no efi was detected during the yunohost install. Even though windows 11 did have an efi section. I just partitioned and created a new one just in case that was the solution. This is my first time venturing into this realm so I am probably off the mark most times

I got yunohost to boot up to that point (aka) the bios was willing to grab the USB over the internal boot and I had started the graphical install process.

I will attempt to download and install Debian 11 as I saw that was a solution in a previous support thread when I had tried to Google the solution but it was when Debian 11 had just come out and honestly I’m very slow with all this. I am trying my best to keep up but I’ve only worked on anything windows related up to this point. I am not afraid to eff around on windows since I’ve been using a Windows PC since I was like 6 so I know if I go to far on that I can just do a clean wipe and try again. All of this is a little scary to me.

I just wanted to create a server I can keep movies on, access like a Google doc, and give my friend a place to upload all her social media images for cheap since I told her I’d help her on that. Now I feel out of my depth. :sweat_smile:

But I will implement what y’all have suggested tonight after work or tomorrow evening and I’ll get back to you. I thoroughly appreciate all of your time!

Before you begin, you will have to resize the Windows partition so there is space on the disk to install Debian. This is best done from within Windows itself (least chance of damaging the filesystem).

The Debian installer should notice there is an EFI partition. Just bear in mind you want to mount the EFI partition, but not format it because it has Windows stuff on there too.

If you get stumped anywhere, just take a screenshot or a photo and upload it to the thread. Most likely someone will be able to give you a hand. :slight_smile:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.