Echec installation Immish

Mon serveur YunoHost

Matériel: Raspberry Pi 4 à la maison
Version de YunoHost: 11.2.11.3
J’ai accès à mon serveur : Par la webadmin | En direct avec un clavier/écran
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non
Si oui, expliquer:
Si votre requête est liée à une applicatio, précisez son nom et sa version: immich 1.103.1~ynh2

Description du problème

Bonjour,
Je tente d’installer l’application Immish par l’intermédiaire de la webadmin. L’ Installation s’arrete subitement et le script finit en supprimant ce qui a été installer, je joint le lien yunopaste avec les logs.

Merci d’avance

Pierre

https://paste.yunohost.org/raw/nijijovico

Bonjour,
même problème pour moi, avec une erreur finale mais pas de signe évident dans le log.
Thomas.

Hello,

Après quelques recherches, voici quelques explications que j’ai trouvé et ce que vous pouvez tenter de faire:

L’erreur Impossible de trouver le package 'libpython3-dev indique que le package libpython3-dev n’est pas installé sur votre système. Ce package est nécessaire pour le bon fonctionnement de l’application Immish.

L’Erreur de dépendance : le package ‘python3-setuptools’ n’est pas installé. Vous devez l’installer avant de pouvoir installer ‘python3-magic’ est évidente :slight_smile: Vous devez installer le package python3-setuptools qui est une dépendance du package python3-magic, qui est lui-même une dépendance d’Immish.

Installez les packages manquants en exécutant les commandes sudo apt install libpython3-dev python3-setuptools dans votre terminal YunoHost

Une fois ces packages installés, essayez d’installer Immish à nouveau en utilisant la webadmin.

Bonne chance!

Je pense que ta réponse est hors sujet, il n’y a aucune mention de l’erreur que tu cites dans le log.

sed: -e expression #1, char 14: unterminated `s’ command
there is something

is the error

Wi-Fi is currently blocked by rfkill.
Use raspi-config to set the country before use.

is the root cause that make failing the helper ynh_replace_string

the issue is not related to immich but due to not full configured system
additionally see installation error · Issue #31 · YunoHost-Apps/immich_ynh · GitHub