Échec à l'installation de YunoHost - problème de dépendances : dh-autoreconf

, ,

Bonjour à tous,

je suis débutant avec Yunohost et me permets de vous contacter car je rencontre un problème lors de son installation.

Mon serveur YunoHost

Matériel: VPS acheté en ligne
Version de YunoHost: la dernière je suppose puisque je l’installe directement depuis le site d’installation de Yunohost
J’ai accès à mon serveur : En SSH
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

Mon OS sous-jacent est Debian 9 (64 bit) and j’ai suivi les instructions d’installation manuelles pour YunoHost.

Mon VPS est tout nouveau.
Après l’installation de quelques packages, l’installation s’est arrêtée avec l’erreur suivante :

Installation of Yunohost packages failed

Le fichier de log généré dans le répertoire /var/log indique qu’un problème a été rencontré avec dh-autoreconf:

dpkg: dependency problems prevent configuration of dh-autoreconf:

Seriez-vous en mesure de m’aider ?

En vous remerciant par avance de votre réponse,



Hi everyone-

I am a newbie with YunoHost and I just tried installing it onto a VPS.

My YunoHost server

Hardware: VPS bought online
YunoHost version: the latest I suppose since I am installing it through the Yunohost installation site
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

The underliying OS is Debian 9 (64 bit) and I followed the manual installation instructions.
My VPS is entirely brand-new.
After some time of going through the installation process, it yielded the following error message:

Installation of Yunohost packages failed

The log file generated in the /var/log folder indicates a problem occurred with dh-autoreconf:

dpkg: dependency problems prevent configuration of dh-autoreconf:

Would you be able to help me out here?

Thanks in advance for your answer.



That’s a known issue, c.f. :


But that doesn’t prevent you from going forward, you can run the postinstall just fine

Thank you Aleks for your response.
I have launched the first post-installation command:

yunohost tools postinstall

Unfortunately, this command fails on my VPS server: I indeed get the following error message:

command not found.

Would you, or anyone, know how I should investigate (and hopefully solve) this further?

Thanks in advance for your help,



On dirait bien que Yunohost n’est pas installé…
It seems that Yunohost is not installed…

I’m certainly going to say something stupid: can you install a ready-made Yunohost image on your VPS?
That doesn’t mean it works…

The issue about debhelper / dh-autoreconf should be fixed with the new version of the install script (from yesterday)

But if the yunohost command is not available then I would suspect that it’s a bigger issue …

Any chance that you can share the full install log ?

Ooooor note that maybe running dpkg --configure -a may solve the issue

Hello Aleks-

Thank you once again for your response.

Following your response, I re-ran the installation process from the exact server where the first installation was attempted: It did not work (An error message displayed indicating something to the effect that YunoHost wasnot able to resume the installation from where it had stalled).

So I went ahead and reinitialized the VPS entirely, going back to the “bare” Debian 9 (64 bit) distribution. From there, I re-ran the installation of YunoHost

curl https://install.yunohost.org | bash

And it worked like a charm this time! :slight_smile:


I don’t know what was fixed in the yesterday’s build but it solved the problem!
Thank you very much for your help.



1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.