Dyndns/let's encrypt not working after reset domain

My YunoHost server

Hardware: VPS bought in my country (Vietnam)
YunoHost version: 3.6.4.3
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: I have my default domain reset one time at Nohost domain recovery - Suppression de domaine en nohost.me, noho.st et ynh.fr

Description of my issue

After following the guide, my server is unreachable using the nohost.me domain (I have tried noho.st and ynh.fr as well).

I can’t update the dyndns and I can’t renew SSL certificate as a result.

I have read about the very same problem at Dyndns/let's encrypt failing and try to have my domain reset one time (the link above). However, the problem still persists.

Here is the log when I ran sudo yunohost dyndns update --debug (I can’t run log display. It freeze for some reason)

https://paste.yunohost.org/icijelaqad.coffeescript

I don’t know if this helps, but my admin interface shows an error An instance is already running very often even when I don’t SSH to the server at that time. I found the same error here "An instance is already running" after openvpn install but I don’t have OpenVPN on my server (I haven’t installed any apps because DNS problem)

Also, during the installation I met an error Could not configure ‘debhelper:amd64’ during installation as mentioned here Could not configure 'debhelper:amd64' during installation but the post-installation continued normally.

Eh, that is weird … Never saw this kind of error with nsupdate yet :

; Communication with 91.224.148.92#53 failed: operation canceled
; Communication with 2a03:7220:8080:5c00::1#53 failed: operation canceled
dns_request_createvia3: not implemented

If you are able to connect through SSH, can you try to run :

dpkg --list | grep dnsutils

and see if you got version 1:9.10.3.dfsg.P4-12.3+deb9u5 (amd64, supposedly) ?

(or at least something similar)

Yeah, when I run dpkg --list | grep dnsutils it shows amd64

ii dnsutils 1:9.10.3.dfsg.P4-12.3+deb9u5 amd64 Clients provided with BIND

Edit: Now I can run log display, so here is the log:

args:
  domain: null
  dyn_host: dyndns.yunohost.org
  ipv4: null
  ipv6: null
  key: null
ended_at: 2019-07-13 03:34:13.368505
error: Unable to update IP address on DynDNS
operation: dyndns_update
related_to:
- - domain
  - stoadmin.nohost.me
started_at: 2019-07-13 03:32:01.384928
success: false

============

2019-07-12 23:32:01,389: INFO - Updated needed, going on...
2019-07-12 23:32:02,628: DEBUG - Could not get public IPv6 : Invalid url https://ip6.yunohost.org (does this site exists?)
2019-07-12 23:32:02,630: DEBUG - system hook folder not found for action 'custom_dns_rules' in /usr/share/yunohost/hooks/
2019-07-12 23:32:02,631: DEBUG - custom hook folder not found for action 'custom_dns_rules' in /etc/yunohost/hooks.d/
2019-07-12 23:32:02,634: DEBUG - Now pushing new conf to DynDNS host...