Dpkg errors with anthy/uim while migrating to buster

,

My YunoHost server

Hardware: Old laptop or computer
YunoHost version: 3.8.5
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: I’ve also installed kodi on it

Description of my issue

Hi everyone,

I got an error while migrating to buster, I try to follow what errors messages said:

La migration 0015_migrate_to_buster a échoué avec l’exception Vous ne pouvez pas faire ça maintenant car dpkg/apt (le gestionnaire de paquets du système) semble avoir laissé des choses non configurées. Vous pouvez essayer de résoudre ce problème en vous connectant via SSH et en exécutant `sudo apt install --fix-broken` et/ou `sudo dpkg --configure -a'. : annulation

https://paste.yunohost.org/raw/kazupuqila (note : this is not the original migration log, but log I got when I try to relaunch the migration)

I tried both sudo apt install --fix-broken and `sudo dpkg --configure -a’:

sudo apt install --fix-broken
dpkg: considering deconfiguration of uim-anthy, which would be broken by installation of uim-data …
dpkg: yes, will deconfigure uim-anthy (broken by uim-data)
(Reading database … 282083 files and directories currently installed.)
Preparing to unpack …/uim-data_1%3a1.8.8-4+deb10u3_all.deb …
De-configuring uim-anthy (1:1.8.6+gh20161003.0.d63dadd-2) …
Error: in load: file “/usr/share/uim/lib/sigscheme-init.scm” not found
dpkg: error processing archive /var/cache/apt/archives/uim-data_1%3a1.8.8-4+deb10u3_all.deb (–unpack):
installed uim-anthy package pre-removal script subprocess returned error exit status 1
Errors were encountered while processing:
/var/cache/apt/archives/uim-data_1%3a1.8.8-4+deb10u3_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

sudo dpkg --configure -a
Setting up uim-mozc:amd64 (2.23.2815.102+dfsg-4) …
Error: in load: file “/usr/share/uim/lib/sigscheme-init.scm” not found
dpkg: error processing package uim-mozc:amd64 (–configure):
installed uim-mozc:amd64 package post-installation script subprocess returned error exit status 1
dpkg: dependency problems prevent configuration of anthy:
anthy depends on libanthyinput0; however:
Package libanthyinput0 is not installed.
dpkg: error processing package anthy (–configure):
dependency problems - leaving unconfigured
dpkg: dependency problems prevent configuration of uim-qt5:
uim-qt5 depends on uim (= 1:1.8.8-4+deb10u3); however:
Version of uim on system is 1:1.8.6+gh20161003.0.d63dadd-2.
uim-qt5 depends on uim-qt5-immodule (= 1:1.8.8-4+deb10u3); however:
Package uim-qt5-immodule is not installed.
uim-qt5 depends on uim-data (>= 1:1.8.8-4+deb10u3); however:
Package uim-data is not installed.
dpkg: error processing package uim-qt5 (–configure):
dependency problems - leaving unconfigured
Errors were encountered while processing:
uim-mozc:amd64
anthy
uim-qt5

I tried to remove uim/anthy but apt seems completly broken :confused:

Does someone has an idea ?
Thanks !

Hmmm first I think you can run rm /etc/apt/sources.list.d/sury.list … but that’s not gonna fix the main issue about uim / anthy

Do you know what these packages are or why they’re here ?

What’s the return of apt remove anthy uim ?

Thanks for your answer,

No I don’t know these packages… seems to be related to japanese language (?!) they may have been installed with xfce ?

sudo apt remove anthy uim
Reading package lists… Done
Building dependency tree
Reading state information… Done
You might want to run ‘apt --fix-broken install’ to correct these.
The following packages have unmet dependencies:
libuim-custom2 : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
libuim-scm0 : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
libuim8 : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
uim-anthy : Depends: libuim-plugins (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
Depends: anthy but it is not going to be installed
uim-fep : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
uim-gtk2.0 : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
uim-gtk3 : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
uim-qt : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
uim-qt5 : Depends: uim (= 1:1.8.8-4+deb10u3) but it is not going to be installed
Depends: uim-qt5-immodule (= 1:1.8.8-4+deb10u3) but it is not going to be installed
Depends: uim-data (>= 1:1.8.8-4+deb10u3) but it is not going to be installed
uim-utils : Depends: libuim-plugins (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
uim-xim : Depends: uim-common (>= 1:1.8.6+gh20161003.0.d63dadd-2) but it is not installable
E: Unmet dependencies. Try ‘apt --fix-broken install’ with no packages (or specify a solution).

Hmpf okay let’s try this then :

apt remove anthy uim libuim-custom2 libuim-scm0 libuim8 uim-anthy uim-fep uim-gtk2.0 uim-gtk3 uim-qt  uim-qt5 uim-utils uim-xim uim-common

thanks,

now sudo dpkg --configure -a and sudo apt --fix-broken install seems ok, i’m gonna relaunch the migration

Migration successfully done !

thanks a lot !

Hi again,

After few days, I notice some problems on my server :confused:
First, it seems to crash almost everday, can’t access web admin or any app and can’t connect via ssh.

I check the diagnostic page and got this : https://paste.yunohost.org/raw/joxovefike

I then tried to update yunohost and yunohost-admin manually via apt but I got this message :

sudo apt upgrade
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Calculating upgrade... Done
The following packages have been kept back:
  yunohost yunohost-admin
0 upgraded, 0 newly installed, 0 to remove and 2 not upgraded.

Do you have any idea ? Can my daily crash comes from these versions ?

Thanks

I doubt … But anyway let’s run :

apt-mark unhold yunohost
apt-mark unhold yunohost-admin
apt install yunohost yunohost-admin

to try to clarify why they ain’t installed/upgraded

That gives me:

$ sudo apt-mark unhold yunohost
yunohost was already not hold.

$ sudo apt-mark unhold yunohost-admin
yunohost-admin was already not hold.

$sudo apt install yunohost yunohost-admin
Reading package lists... Done
Building dependency tree       
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 yunohost : Depends: python-requests but it is not going to be installed
            Depends: openssl but it is not going to be installed
            Depends: ca-certificates but it is not going to be installed
            Depends: libnss-ldapd but it is not going to be installed
            Depends: libpam-ldapd but it is not going to be installed
            Depends: postfix but it is not going to be installed
            Depends: postfix-ldap but it is not going to be installed
            Depends: postfix-policyd-spf-perl but it is not going to be installed
            Depends: postfix-pcre but it is not going to be installed
            Depends: dovecot-core but it is not going to be installed
            Depends: dovecot-ldap but it is not going to be installed
            Depends: dovecot-lmtpd but it is not going to be installed
            Depends: dovecot-managesieved but it is not going to be installed
            Depends: dovecot-antispam but it is not going to be installed
            Depends: rspamd but it is not going to be installed
            Depends: metronome (>= 3.14.0)
            Recommends: python-pip but it is not going to be installed
E: Unable to correct problems, you have held broken packages.

Let’s look at apt policy openssl

Here is the result

$ sudo apt policy openssl
openssl:
  Installed: 1.1.1g-1+0~20200421.17+debian9~1.gbpf6902f
  Candidate: 1.1.1g-1+0~20200421.17+debian9~1.gbpf6902f
  Version table:
     1.1.1g-1+0~20200421.17+debian10~1.gbpf6902f -1
        600 https://packages.sury.org/php buster/main amd64 Packages
 *** 1.1.1g-1+0~20200421.17+debian9~1.gbpf6902f 100
        100 /var/lib/dpkg/status
     1.1.1d-0+deb10u3 500
        500 http://ftp.fr.debian.org/debian buster/main amd64 Packages
        500 http://security.debian.org/debian-security buster/updates/main amd64 Packages
        500 http://deb.debian.org/debian buster/main amd64 Packages

So let’s do a

apt install openssl=1.1.1d-0+deb10u3 --allow-downgrades

After that, I launched apt update and apt upgrade and all looks good !

Thanks a lot for your time :slight_smile:

cheers
Simon

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.