Dnsmasq keep failing #2

I’m using YunoHost version (stable) and from two days I’m facing with a dns issue.

I’m using Adguard Home installed on a dedicated VM with DHCP and DNS activated.
For the yunohost server it’s static @IP with the DNS from the router (livebox) of the service provider and not adguard home.

I have check similar issue on this forum and founded this topic: Dnsmasq keep failing

But it seems that Adguard Home is installed on the same computer here and mine is not.

There are the error message that I have on my yunohost:

Description of my issue

root@xxxx:~# journalctl -u dnsmasq -n 100 --no-hostname --no-pager
-- Logs begin at Tue 2021-09-21 09:18:08 CEST, end at Tue 2021-09-21 10:21:40 CEST. --
sept. 21 09:18:09 systemd[1]: Starting dnsmasq - A lightweight DHCP and caching DNS server...
sept. 21 09:18:09 dnsmasq[556]: dnsmasq: vérification de syntaxe OK.
sept. 21 09:18:09 dnsmasq[574]: dnsmasq: impossible de créer une socket d'écoute pour port 53 : Adresse déjà utilisée
sept. 21 09:18:09 dnsmasq[574]: impossible de créer une socket d'écoute pour port 53 : Adresse déjà utilisée
sept. 21 09:18:09 systemd[1]: dnsmasq.service: Control process exited, code=exited, status=2/INVALIDARGUMENT
sept. 21 09:18:09 dnsmasq[574]: IMPOSSIBLE de démarrer
sept. 21 09:18:09 systemd[1]: dnsmasq.service: Failed with result 'exit-code'.
sept. 21 09:18:09 systemd[1]: Failed to start dnsmasq - A lightweight DHCP and caching DNS server.
root@arjz:~# sudo netstat -tnlp | grep :53
tcp        0      0  *               LISTEN      444/systemd-resolve
tcp        0      0 *               LISTEN      444/systemd-resolve
tcp6       0      0 :::5355                 :::*                    LISTEN      444/systemd-resolve

I receive also lot of email from yunohost dyndns update cron like that every 10 minutes:

Cron <root@arjz> : YunoHost DynDNS update; sleep $((RANDOM%60)); test -e /var/run/moulinette_yunohost.lock || yunohost dyndns update >> /dev/null

Failed to resolve dyndns.yunohost.org

There is my /etc/network/interfaces:

# This file describes the network interfaces available on your system
# and how to activate them. For more information, see interfaces(5).

source /etc/network/interfaces.d/*

# The loopback network interface
auto lo
iface lo inet loopback

# The primary network interface
allow-hotplug ens18
iface ens18 inet static
address 192.168.111.x (@IP yunohost)
gateway 192.168.111.x (@IP router)
dns-nameservers 192.168.111.x (@IP router)


# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
nameserver 192.168.111.x (@IP router)




nameserver 192.168.111.x (@IP router)

If someone can help, it will be greatly appreciate
Thank you

Sounds like systemd-resolved took over the dns resolution …

Should be fixed with:

systemctl disable systemd-resolved --now
systemctl restart dnsmasq
1 Like

Thank you aleks, yes you are right.
I don’t know why systemd-resolved has been enabled but now dyndns and dnsmasq are ok.

I’ll close this topic.

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.