DNS records (Diagnosis)

My YunoHost server

Hardware: Raspberry Pi at home (version 4B; 4GB)
YunoHost version: (stable).
I have access to my server : Through SSH (with local IP address)| through the webadmin (with local IP address) |
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain:
Disabled IPv6 (Method 1 from this tutorial Disable IPv6)

Description of my issue

Newbie mode. :grin:
I’m following yunohost documentation (section 5). My domain is in format mydomain.noho.st
From the web interface I tried to install Let’s Encrypt certificate but I’m unable to do it due to this message

This domain doesn't seem ready for a Let's Encrypt certificate. Please check your DNS configuration and HTTP server reachability. The 'DNS records' and 'Web' section in the diagnosis page can help you understand what is misconfigured.

so I went into Diagnosis section and found problems with DNS records (category basic and category mail). This part is a bit confusing to me since recommended configuration from Diagnosis is already part od DNS configuration (Home->Domains->DNS configuration). Screenshot from Diagnosis.

If I try with this command (SSH into server with local IP address)

yunohost dynds update --force

all I get is error pointing to Home->Tools->Logs and there I have (with 10 min distance) bunch of

Update the IP associated with your YunoHost subdomain 'mydomain.noho.st'


  domain: null
  dry_run: false
  dyn_host: dyndns.yunohost.org
  force: false
  ipv4: null
  ipv6: null
  key: null
ended_at: 2021-08-30 15:20:30.063253
error: Could not update IP address to DynDNS
interface: cli
operation: dyndns_update
parent: null
- - domain
  - maindomain.tld
started_at: 2021-08-30 15:20:29.987907
success: false


2021-08-30 17:20:30,007: INFO - Updated needed, going on...
2021-08-30 17:20:30,009: DEBUG - Reusing IPv4 from cache: xx.xx.xx.xx
2021-08-30 17:20:30,009: DEBUG - Reusing IPv6 from cache: None
2021-08-30 17:20:30,012: DEBUG - Now pushing new conf to DynDNS host...

I’m unable to:

  1. connect to mydomain.noho.st outside of my local network (e.g. through 4G/5G network)
  2. DNS propagation checker https://dnschecker.org/ can’t reach mydomain.noho.st

If I search, outside of my local network, (e.g. through 4G/5G network) for my global IP address then I land on yunohost/admin/ web page with option to login with administration password.

Can you help me out troubleshoot this one? I know it has something to do with dyndns and my IP address but at this moment I’m just chasing my own tail…

1 Like

[SOLVED] On router level Adblock was blocking some instances of yunohost server. For the time being Adblock is disabled just to see what yunohost is offering :slight_smile:

If you know which instance should I whitelist in Adblock for functional yunohost server let me know!

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.