DNS over WiFi Hotspot App

My YunoHost server

Hardware: Raspberry Pi at home
YunoHost version: (stable)
I have access to my server : Through SSH | through the webadmin |
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no

Description of my issue

TL;DR: Name Resolution does not work


  • ISP router
  • YNH raspi Ethernet connected to router
  • Installed Hotspot App in YNH to create a Wi-Fi hotspot that other devices at home could connect and access internet
  • Hotspot successfully installed, other devices can connect to it via WiFi
  • Default config for Hotspot App (subnetwork 10.0.242 created AND DNS RESOLVER)


Devices get an IP on 10.0.242.x but have no access to internet

but can ping IPs on internet. This is from one computer connected to Hotspot

[user@pc ~]$ ping google.com
ping: google.com: Temporary error in name resolution
[user@pc ~]$ ping
PING ( 56(84) bytes of data.
64 bytes from icmp_seq=1 ttl=59 time=16.7 ms
64 bytes from icmp_seq=2 ttl=59 time=20.2 ms
64 bytes from icmp_seq=3 ttl=59 time=17.8 ms
64 bytes from icmp_seq=4 ttl=59 time=20.9 ms
[1]+  Stopped                  ping

I’ve changed DNS Resolvers value in webinterface admin panel for Hotspot App to and

but had no name resolution neither.


so I guess dnsmasq is doing its thing, so hostapd, but something is messing with name resolution.

I’ve tested with two devices on the network, both have no name resolution.


I’ve tried to enable ipv4 forwarding in /etc/sysctl.conf (it is disabled by default), but made no difference.

this is ifconfig value when connected to hotspot

 wlo1: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet  netmask  broadcast

I suggest you to run this command after adding an usb antenna (you can try to do it anyway)

yunohost tools regen-conf dnsmasq --force

And retry to connect

Could i suggest you to not use and and prefer one of this list ?

1 Like

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.