Discourse upgrade fails, restoring backup fails too

Hi all,
I’ve got a problem: Updating Discourse failed with message:

error: An error occurred inside the app upgrade script

Automatic backup restore failed too. Log: https://paste.yunohost.org/raw/abofimador
Attempt to restore a backup manually also failed: https://paste.yunohost.org/raw/yecimofuza

I’ve got an impression that ruby version is too low, 2.7 instead of required 3, but I couldnt find instructions how to upgrade it… If that’s even the actual problem.

Thanks in advance, if you take time to help…

My YunoHost server

Hardware: Old laptop or computer
YunoHost version: 11.2.10
I have access to my server : Through SSH
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If your request is related to an app, specify its name and version: app 2.8.14~ynh2