Discourse installation problem

Tried to install a second instance of discourse several times, but it fails: https://paste.yunohost.org/raw/vaxidanace

Anyone a hint?

Hmmmm yeah the issue seems to come from the fact that the line

client_max_body_size 10m;

Can’t be two times in the same virtualhost configuration …

So it indeed looks like there’s a small limitation of the app preventing it to be installed two times on the same exact domain …

1 Like

Thanks for your support!

Do you know if a deinstallation of the current installation should solve the issue so I can install a fresh discourse forum?
The problem is, I don’t have admin access to the current installation since I lost the admin password.

Well uh then uninstalling sounds like overkill, I would first try to reset the admin password from the CLI but I don’t know enough about Discourse specifically to know how it’s done…

1 Like

It’s weird, shouldn’t the normal yunohost main user login work for the discourse login too? It does not and I can’t imagine that I changed the password.

I found this one to create an admin account from CLI: https://meta.discourse.org/t/create-admin-account-from-console/17274
Does this also work for discourse on yunohost or do I have to be careful?

Edit: solved my problem: the yunohost standard root login works if I press on “LDPA”. Kept pressing on “Login” which doesn’t work. Not very intuativ, I’d say a little bug.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.