Difficulties to install with Docker

,

Hi,
I’ve tried to install the Yuno Docker but I can’t do anything, don’t know what happens, etc so I’m trying a different way.

Starting from the Yuno Dockerfile, I keep only the first lines until the run of the install script, and commited this container. That’s my starting image.

Then, instead of running the autoinstall script, I’m trying to run the install_yunohostv2 script. Almost everything runs almost fine, but in the end, the script says “installation failed”.

Errors I noticed:

======== Checking domain ========
hostname: you must be root to change the host name

======== Install ========
[ ok ] Stopping OpenLDAP: slapd.
[FAIL] Starting OpenLDAP: slapd failed!

[…] Reloading domain name service…: bind9rndc: connect failed: 127.0.0.1#953: connection refused
failed!
[ ok ] Restarting Metronome XMPP Server: metronome.
[ ok ] Reloading nginx configuration: nginx.
Error: An error occured during LDAP operation

And here, there is nothing I can do. Any idea? How can I diagnose this?

Thanks.

Hi @romu70

May I suggest you to try my shinny new attempt to make a proper Dockerfile ? :smile:

https://yunohost.org/docker

docker pull yunohost/full
docker run -d yunohost/full

Your feedbacks are very welcomed though :blush:

So, same people on all of those self hosting projects, great!

Much better, it works basically. Some issues:

  • I’ve my own domain and certificate, but can’t seasily set this certificate, so once the domain is set, Firefox refuses to browse Yuno, works with Webkit based browser tough
  • “glances can’t be activated”, no more detailed error message, don’t know if this is a big deal or not, didn’t search yet.
  • tried to install some apps (wallabag, ttrss, baikal), it failed, error message displayed on the page is: “No passwd entry for user ‘admin’”

I’ve the same basic needs as the ones expressed on the Cozy forum:

  • being able to run Yuno with my own certificate (my feeling is this shoul not be too difficult)
  • map user data folder to the host to be sure to get my data back in case of a container crash, but I’ve some doubts, as all packaged applications embed data in different ways I guess.

Useful commands
Hi, some one can tell me how run yunohost container via HAProxy? here my run script:

docker run -d -e VIRTUAL_HOST=yh.jujes.dev --name yunohost yunohost/full /sbin/init

docker run -d -p 25:25 -p 53:53/udp -p 80:80 -p 443:443 -p 465:465 -p 993:993 -p 5222:5222 -p 5269:5269 -p 5290:5290 --link yunohost:yunohost tutum/haproxy

Ingredients:
docker pull tutum/haproxy
https://registry.hub.docker.com/u/tutum/haproxy/

docker pull yunohost/full
https://registry.hub.docker.com/u/yunohost/full/

Thanks in advance,

I didn’t make the Dockerfile, but it doesn’t look it would be a good fit behind an HAProxy. Containers behind an HAproxy should be either aware of each other or using a shared data source of some sort so traffic that hits one node, the other node will be aware of any changes.

Hi @romu70 I have the same issue = No passwd entry for user ‘admin’ Installation failed how you fix it?
and why the port 80 is not EXPOSE? some one know about it?? here the Dokerfile
https://registry.hub.docker.com/u/yunohost/full/dockerfile/

Hi @jujes,
The port 80 is not exposed because all is done through HTTPS, so on port 443.

I didn’t fix the issue, I just gave up with Yuno for the moment, indeed, I don’t have the time to setup my cloud and have no real solution for the time being.

Hi, to fix the “no passwd” error:

  1. Find the docker ID : “docker ps” and look for the ID of the yunohost container
  2. docker exec -t -i <ID_de_mon_conteneur> /bin/bash
  3. useradd admin
  4. passwd admin

Vous avez ainsi un utilisateur admin avec password à l’intérieur du conteneur Yunohost