Did somebody managed to have a Gancio instance running with YNH?

I need advice about this app. Cheers

Hey,

This kind of polling open questions usually do not work. :wink:

Gancio is currently packaged with a good integration level, so please state your issue and move your thread in the Support section. :slight_smile:

1 Like

Good integration but not working :woozy_face:

Thanks for your replay.
You can close the topics.

Thank you for linking to the issue you opened, it gives more context. :slight_smile: Let’s keep the thread open here.

The last changes should have made us closer to a really working app : v1.15 + admin password + screenshot + autoupdate + github templates by lapineige · Pull Request #4 · YunoHost-Apps/gancio_ynh · GitHub

But I haven’t tried myself, and I’m unsure it solved the issue.
We need some people to dig into the issue. I’m not available enough.

@Lapineige

  1. No way to login after install with this version (at least for me on a VPS).

  2. If the package is not working maybe mention it in the README.

Can you try removing the app and installing it with the following command? yunohost app install https://github.com/YunoHost-Apps/gancio_ynh/tree/fix-admin -f

1 Like

@tituspijean
Thanks.

For the moment I used this weird old style fix:

I will test the fix-admin branch later today.

1 Like

Not working…

Doesn’t really help to help.
Share the logs and the output of the console. I know it takes time and effort, but we all try what we can when we get some time. So providing some pieces can help packegers to get fixes.

Good luck

The logs are linked in my Github issue… Look here:

The problem come from the fact that YNH install script doesn’t create the admin user. If I register an user (the first user after install), he become an admin.

tl;dr → The temporary solution is in the @Lesion comment:

you can register an user, the first one will be an administrator

This close this topic (working Glancio Instance) but not the bug in YNH install (main and fix-admin branchs).

1 Like

Solution: Move admin creation after initial service start by tituspijean · Pull Request #20 · YunoHost-Apps/gancio_ynh · GitHub

1 Like

I confirm, problem solved with the fix-admin2 branch.

1 Like

Regression :frowning: