Dex-App: Bad Request Unregistered redirect_uri ("https://pve.<mydomain>.de")

My YunoHost server


  • Hardware: Proxmox Virtual Environment 7 kvm amd64 QEMU Standard PC (Q35 + ICH9, 2009)
  • YunoHost version:
  • I have access to my server: SSH | webadmin | direct access via keyboard / screen
  • Are you in a special context or did you perform some particular tweaking on your YunoHost instance?: no
  • Using, or trying to install package version/branch: 2.35.3~ynh2

Description of my issue


I’ve installed Proxmox Virtual Environment in the LAN on a private IPv4 address and added a tile via the reverse-proxy add-on to Yunohost (https://pve.<mydomain>.de ->

Now it is possible to access the Proxmox Virtual Environment WebUI via the Yunohost reverse-proxy. After that I installed the Dex add-on to configure OpenID-Connect on PVE. When I try to log-in at PVE via OpenID-Connect I get the error message

Bad Request
Unregistered redirect_uri ("https://pve.<mydomain>.de").

from Dex although the callback-URI is set to "https://pve.<mydomain>.de"


time="2023-06-22T14:20:44Z" level=info msg="Dex Version: , Go Version: go1.19.10, Go OS/ARCH: linux amd64"                                                                                                         
time="2023-06-22T14:20:44Z" level=info msg="config issuer: https://<mydomain>/dex-pve"                                                                                                                          
time="2023-06-22T14:20:45Z" level=info msg="config storage: sqlite3"                                                                                                                                               
time="2023-06-22T14:20:45Z" level=info msg="config static client: pve"                                                                                                                                             
time="2023-06-22T14:20:45Z" level=info msg="config connector: ldap"                                                                                                                                                
time="2023-06-22T14:20:45Z" level=info msg="config refresh tokens rotation enabled: true"                                                                                                                          
time="2023-06-22T14:20:45Z" level=info msg="keys expired, rotating"                                                                                                                                                
time="2023-06-22T14:20:45Z" level=info msg="keys rotated, next rotation: 2023-06-22 20:20:45.484431203 +0000 UTC"                                                                                                  
time="2023-06-22T14:20:45Z" level=info msg="listening (http) on"                                                                                                                                    
time="2023-06-22T14:21:18Z" level=error msg="Failed to parse authorization request: Unregistered redirect_uri (\"https://pve.<mydomain>.de\")."

Does anyone have an idea what’s going wrong?
How can I debug this?

Thanx for any hint! :smile:

i just tried the Reverse Proxy to proxmox it works

Choose the domain where this app should be installed:
Choose the URL path (after the domain) where this app should be installed: /
Redirect destination path (unix:/file for socket):

it worked, so odd https didnt work before, but its working now i was able to access proxmox.

does this help? Failed to parse authorization request: Unregistered redirect_uri (\"\" · Issue #1145 · dexidp/dex · GitHub

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.