Désactiver la mise en veille lors de la fermeture de l'écran

Bonjour,
J’ai installé la dernière version de Yunohost sur un vieux PC portable, mais il se met en veille (et devient donc inaccessible) dès que j’en ferme l’écran. J’ai déjà essayer de modifier le fichier /etc/systemd/logind.conf mais sans succès :confused:.

Hi,
I installed the latest version of Yunohost on an old laptop, but it goes to sleep (and therefore becomes inaccessible) as soon as I close the lid. I have already tried to modify the /etc/systemd/logind.conf file but without success :confused:.

1 Like

Bonjour,
Navrée si ça ne répond pas à la question, mais j’avais eu ça à un moment pour un essai de serveur :

  • dans /etc/systemd/logind.conf on peut modifier la ligne
    HandleLidSwitch=xxx
    par HandleLidSwitch=ignore (et décommenter cette ligne en effaçant le # devant s’il existe)

  • si ça ne marche pas dans le fichier /etc/default/acpi-support il faudrait commenter la ligne LID_SLEEP=true

  • l’autre possibilité encore : une option dans le bios par exemple?

@Olomorn Merci de nous faire un retour si une des solutions ci-dessus fonctionnent

Merci de votre réponse, je ne suis pas chez moi avant le 9 pour essayer, donc je ne pourrai pas faire de retour avant cette date. Je sais par contre que j’avais déjà essayé de modifier le fichier logind.conf et que cela n’avait pas fonctionné. Je suis aussi à peu près sûr que ça n’est pas dans le bios car je n’y ai pas touché depuis belle lurette, alors que mon problème est très récent.
Il reste acpi-support mais comme mentionné avant, je ne vais pas pouvoir essayer de suite.
Merci pour votre aide

okay, donc j’ai pu regarder tout ça et en effet, modifier le fichier “logind.conf” ne change rien, j’avais déjà vu la solution du fichier “acpi-support” mais il n’existe même pas sur ma machine, et enfin je n’ai rien trouvé dans les options du bios :confused:

¯_(ツ)_/¯
J’ai peur que cela ne sorte du champ de mes maigres compétences. Pour l’acpi, le fichier devrait exister si votre ordinateur gère l’acpi, mais il pourrait aussi être un peu trop vieux pour que lors de l’installation linux configure ça correctement, un peu comme ici :
https://www.linuxquestions.org/questions/slackware-14/how-to-enable-acpi-573178/
également là :
http://www.thinkwiki.org/wiki/How_to_make_ACPI_work
qui parle aussi plus spécifiquement du cas de vieux Thinkpad.

L’autre solution hardcore serait d’ouvrir la bête pour shunter le switch/capteur du capot :nerd_face:
Sinon n’hésitez pas aussi à nous indiquer le modèle exact de votre laptop qui a peut-être des besoins particuliers :smile:
Bonne chance :slight_smile:

Peut être y a t’il un environnement graphique sur serveur ?

Par curiosité, l’installation de cette machine a été faite avec l’iso OU à partir de l’installation d’une debian ?

Si c’est le second cas, est-ce qu’un environnement graphique a été installé lors de l’installation de debian ?

Sinon, peut être qu’en faisant apt install vim tu as installé sans le vouloir l’environnement graphique. Rappel, il faut faire “apt install vim-nox”.

Que dit

dpkg -l | grep xorg

Je ne pense pas que j’ai d’environnement graphique installée. J’ai utilisé l’iso fournie par yunohost et c’est tout, je crois même que je n’ai installé manuellement aucun paquet.
La commande que tu m’as demandé d’entrer ne retourne rien, je suppose que c’est une bonne chose ?

Mon ordinateur n’est pas si vieux que ça, c’est un portable Dell Inspiron d’à peu près 8 ans. Je vais essayer, d’activer acpi mais ça a l’air un peu complexe, je tenterai ça quand j’aurai un peu plus de temps ^^’
Et je ne suis pas prêt à triturer les entrailles de mon PC pour le moment, je pense que ça sera en dernier recours :3
Merci pour votre aide

Il reste les options à passer au boot :
https://www.linuxquestions.org/questions/mandriva-30/disable-hibernate-suspend-on-desktop-dell-inspiron-531s-581763/#post2880896

et ici? :

(pistes sous forme de liens, j’ai peur de mal expliquer quelque chose que je ne comprends pas trop moi-même surtout :sweat_smile:)
Sinon, comme je l’ai dit, ça sort de mes compétences donc bonne chance :slight_smile:

Bonjour,

J’ai le même problème, et j’ai tenté la manière brute :
https://wiki.debian.org/Suspend

sudo systemctl mask sleep.target suspend.target 

puis j’ai redémarré,

et là l’écran est rabattu et ça marche toujours :dancer:
(en pratique, ça ignore tous les messages de mise en veille)

1 Like

Merci Nartagnan !