Deleted user still shows up in app permission

Hi everyone!

I’ve recently added a new user, and deleted another one.
While checking the permissions on one of my app (Custom Web app with SFTP access), I saw that the old user account is still showing up.

On the app info page, the old user account is shown with its username. On the Access page, it shows up as undefined:
And of course, I can’t remove it from the app access list since it’s undefined :smiley:
I’m not sure if that’s a known bug. Is there a way to try and clean this up?


Hm that’s weird :confused:

I think you can try yunohost app ssowatconf

I got this from the cli:

Success! The SSOwat configuration has been generated

It didn’t solve the problem though.
Using the web tools from firefox, I tried to edit the link on the app access page, changing the https://domain.tld/yunohost/admin/#/apps/my_webapp/access/remove/ to https://domain.tld/yunohost/admin/#/apps/my_webapp/access/remove/oldUserName

After clicking it, it apparently worked.

Although now I’m not sure if there’s still some leftover of that user somewhere.