Debian Jessie released

Hi folks,

Debian Jessie has been released :wink:

As you know we are actually working on YunoHost 2.2.
For more information about the improvement read the roadmap.
Our future work, for YunoHost 2.2, will be the migration to Debian Jessie.

Do not upgrade to Debian Jessie, because this could break your instance.

That is a very good news !

And yes i also tried (by curiosity) to upgrade to jessie on a test instance, and indeed it totally breaks it!

Very good news indeed!

Just to be sure: will Yunohost rely on systemd?

Hello,

I’ve just read these news, just a little bit too late… ;-/

My habit is to always put names like “stable” or “testing” in my sources.list: by doing this way, I get a sort of semi-permanent rolling-debian-release.

It usually works well… except today on my yunohost box…
And now I understand why… Oops.
No worries, I’ll wait until 2.1 is out. Or I’ll try to switch back to Wheezy, if I’m in a good mood.
@laskameleonart, did you try downgrading back to Wheezy, for curiosity also?

Cheers, and thanks for the hard work for making Yunohost!
À+
PierreBoulet

Hi Pierre ;

Not i did not, never thought about that, sorry ^^

I am in an adventurous mood this morning, so I’ll try that.
Just in case someone else as dumb as me also scr3wed up, I’ll keep you informed…

At the moment, I just replaced all “stable” by “wheezy” in my

/etc/apt/sources.list

And I run:

apt-get update && apt-get -f dist-upgrade 

Waiting (slow Internet connexion here)…

Ach!

Des erreurs ont été rencontrées pendant l'exécution :
 /var/cache/apt/archives/yunohost-config-tahoe_2.0-rc1~megusta1_all.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

Okay, I’ll try to play with aptitude a bit, to find out what’s going wrong.
—8--- Lunch break (not yet)… —8---

Yep, YunoHost will rely on systemd.

After numerous apt-get’s update, dist-upgrade, aptitude, resolution of conflicts, etc., my yunohost-powered server is miraculously running again.
;o)

I’m always baffled how stable a Debian can be, no matter how hard you try to break it…

Yes, I’m impressed too ! I also update my server, and it is still running. But some stuff is broken (metronome on the raspberry (I had to recompile it), web admin and some applications … ). I’ll certainly reinstall yunohost completely soon.

Oops. I have parled trop vite.
During a little storm yesterday, power went down, and now my server just shows me a grub> prompt… :unamused:

Since jessie is stable : unable to install a new yunohost (with yunohostv2-latest-amd64.iso) . All mirror is for jessie.

Then :
WARNING **: mirror does not support the specified release (wheezy)

:slight_smile:

PS: bug reported : https://github.com/YunoHost/rebuildd/issues/1, hope it’s the good place.

Well, I think I may well have also to re-install yunohost… If your machine runs, just don’t reboot it! I’m stuck now, grub re-installation while chroot’ed has failed, so far.

So, in case of a re-installation of yunohost, is there a procedure to keep or save/restore the data from the previous installation (configuration, data, databases, etc.)?

At the moment, my server is still stuck in a dependency hell, within the chrooted environment, all attempts to restore grub have failed, so far…

Hello,
In the changelog you said you added a backup system.
Can we use it from the web interface? I tried to upgrade my system but this feature did not appear :frowning:
Thanks

Hi,
Things have evolved, in the good direction so that it should be time to upgrade to Debian Jessie by now.
I’m just about to try. Will keep you guys informed…

Well, I haven’t had much luck yet… I may consider restarting all over again, and re-installing a Jessie from scratch…

=> Very unfortunately, that’s what I just did, “la mort dans l’âme”. I tried very hard to recover the previous installation, but I eventually gave up… Sigh.

Fresh Install on Jessie at DigitalOcean successfully
But i’d need to do that before : define a password for root and add a user [yhn] into sudo group

# apt-get install sudo

# passwd root

# adduser yhn

# usermod -a -G sudo yhn

after that I’d reconnect as yhn then
https://yunohost.org/#/install_manually