Date serveur erronée

fr

#1

Bonjour @ tous,

Suite à un arrêt inopiné de la brique plus moyen de redémarrer les services vpn client et hotspot
je e suis rendu compte que la date du serveur n’est pas à jour quelqu’un a une idée de recherche pour essayer de résoudre le problème ou comprendre ce qui ce passe.
Merci d’avance pour vos réponses et votre aide.

Bon week-end et profiter du soleil.

didier58


#2

Pour régler ça rapidement tu peux utiliser la commande date pour indiquer la date.

Ensuite pour régler ça définitivement, il faut:

  • utiliser la dernière version de vpnclient
  • installer fake-hwclock (si pas déjà fait)

#3

Salut ljf,

Impossible de mettre vpnclient à jour le systeme me dit que l’application n’est pas installer après désinstallation et essai de réinstallation message d’erreur:

unable to download https://github.com/labriqueinternet/vpnclient_ynh/archive/355b24ea0cd3467d7ba1390ab7d34dd4b2500229.zip

Je suis un peu coincé je ne trouve pas la solution pour avancé.

Merci pour ton aide.

Bonne journée.

didier58


#4

Tu as mis à jour la date avec la commande date ?


#5

oui j’ai fais cela.


#6

Si tu ne ping pas, essaie de redémarer dnsmasq

Si on peut voir le résultat de (la liste des règles parefeu)

iptables-save

et de

ping 9.9.9.9
ping wikipedia.org

#7

voici les différents résultats:

(ping 9.9.9.9)

root@didiercl:~# ping 9.9.9.9
PING 9.9.9.9 (9.9.9.9) 56(84) bytes of data.
64 bytes from 9.9.9.9: icmp_seq=1 ttl=53 time=26.1 ms
64 bytes from 9.9.9.9: icmp_seq=2 ttl=53 time=26.3 ms
64 bytes from 9.9.9.9: icmp_seq=3 ttl=53 time=26.9 ms
64 bytes from 9.9.9.9: icmp_seq=4 ttl=53 time=27.4 ms
64 bytes from 9.9.9.9: icmp_seq=5 ttl=53 time=26.2 ms
^C
— 9.9.9.9 ping statistics —
5 packets transmitted, 5 received, 0% packet loss, time 4005ms
rtt min/avg/max/mdev = 26.151/26.625/27.445/0.488 ms

(ping wikipedia.org)

root@didiercl:~# ping wikipedia.org
ping: wikipedia.org: Échec temporaire dans la résolution du nom

(iptables-save)

root@didiercl:~# iptables-save

Generated by iptables-save v1.6.0 on Mon Jul 2 10:27:48 2018

*nat
:PREROUTING ACCEPT [26542:8496615]
:INPUT ACCEPT [1076:128572]
:OUTPUT ACCEPT [7200:483149]
:POSTROUTING ACCEPT [7177:480725]
-A POSTROUTING -o eth0 -j MASQUERADE
COMMIT

Completed on Mon Jul 2 10:27:48 2018

Generated by iptables-save v1.6.0 on Mon Jul 2 10:27:48 2018

*filter
:INPUT DROP [107:7493]
:FORWARD ACCEPT [4:296]
:OUTPUT ACCEPT [1834:165786]
:f2b-dovecot - [0:0]
:f2b-nginx-http-auth - [0:0]
:f2b-pam-generic - [0:0]
:f2b-postfix - [0:0]
:f2b-postfix-sasl - [0:0]
:f2b-recidive - [0:0]
:f2b-sshd - [0:0]
:f2b-sshd-ddos - [0:0]
:f2b-yunohost - [0:0]
-A INPUT -p tcp -m multiport --dports 80,443 -j f2b-yunohost
-A INPUT -p tcp -j f2b-pam-generic
-A INPUT -p tcp -j f2b-recidive
-A INPUT -p tcp -m multiport --dports 110,995,143,993,587,465,4190 -j f2b-dovecot
-A INPUT -p tcp -m multiport --dports 25,465,587 -j f2b-postfix
-A INPUT -p tcp -m multiport --dports 80,443 -j f2b-nginx-http-auth
-A INPUT -p tcp -m multiport --dports 22 -j f2b-sshd-ddos
-A INPUT -p tcp -m multiport --dports 22 -j f2b-sshd
-A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
-A INPUT -p tcp -m tcp --dport 22 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 25 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 53 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 80 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 443 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 587 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 993 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 5222 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 5269 -j ACCEPT
-A INPUT -p tcp -m tcp --dport 4280 -j ACCEPT
-A INPUT -p udp -m udp --dport 53 -j ACCEPT
-A INPUT -p udp -m udp --dport 5353 -j ACCEPT
-A INPUT -p udp -m udp --dport 67 -j ACCEPT
-A INPUT -p udp -m udp --dport 4253 -j ACCEPT
-A INPUT -p udp -m udp --dport 587 -j ACCEPT
-A INPUT -i lo -j ACCEPT
-A INPUT -p icmp -j ACCEPT
-A f2b-dovecot -j RETURN
-A f2b-nginx-http-auth -j RETURN
-A f2b-pam-generic -j RETURN
-A f2b-postfix -j RETURN
-A f2b-postfix-sasl -j RETURN
-A f2b-recidive -s 91.210.251.210/32 -j REJECT --reject-with icmp-port-unreachable
-A f2b-recidive -s 61.177.172.20/32 -j REJECT --reject-with icmp-port-unreachable
-A f2b-recidive -s 31.193.138.74/32 -j REJECT --reject-with icmp-port-unreachable
-A f2b-recidive -s 118.212.143.47/32 -j REJECT --reject-with icmp-port-unreachable
-A f2b-recidive -j RETURN
-A f2b-sshd -j RETURN
-A f2b-sshd-ddos -j RETURN
-A f2b-yunohost -j RETURN
COMMIT

Completed on Mon Jul 2 10:27:48 2018


#8

Si tu es sur jessie: regarde ça:

que dis

service dnsmasq status
journalctl -u dnsmasq


#9

j’ai déjà migrer sous Stretch

version installer:

yunohost
3.0.0.1 (stable)
yunohost-admin
3.0.0 (stable)
moulinette
3.0.0 (stable)
ssowat
3.0.0 (stable)

(service dnsmasq status)

root@didiercl:~# service dnsmasq status
● dnsmasq.service - dnsmasq - A lightweight DHCP and caching DNS server
Loaded: loaded (/lib/systemd/system/dnsmasq.service; enabled; vendor preset:
Active: active (running) since Mon 2018-07-02 11:07:19 CEST; 6min ago
Process: 11200 ExecStop=/etc/init.d/dnsmasq systemd-stop-resolvconf (code=exit
Process: 11262 ExecStartPost=/etc/init.d/dnsmasq systemd-start-resolvconf (cod
Process: 11253 ExecStart=/etc/init.d/dnsmasq systemd-exec (code=exited, status
Process: 11250 ExecStartPre=/usr/sbin/dnsmasq --test (code=exited, status=0/SU
Main PID: 11261 (dnsmasq)
Tasks: 1 (limit: 4915)
CGroup: /system.slice/dnsmasq.service
└─11261 /usr/sbin/dnsmasq -x /run/dnsmasq/dnsmasq.pid -u dnsmasq -7 /

juil. 02 11:07:18 didiercl.me systemd[1]: Starting dnsmasq - A lightweight DHCP
juil. 02 11:07:18 didiercl.me dnsmasq[11250]: dnsmasq: syntax check OK.
juil. 02 11:07:18 didiercl.me dnsmasq[11261]: started, version 2.76 cachesize 25
juil. 02 11:07:18 didiercl.me dnsmasq[11261]: compile time options: IPv6 GNU-get
juil. 02 11:07:18 didiercl.me dnsmasq[11261]: no servers found in /etc/resolv.dn
juil. 02 11:07:18 didiercl.me dnsmasq[11261]: read /etc/hosts - 10 addresses
juil. 02 11:07:19 didiercl.me dnsmasq[11262]: /etc/resolvconf/update.d/libc: War
juil. 02 11:07:19 didiercl.me systemd[1]: Started dnsmasq - A lightweight DHCP a

( journalctl -u dnsmasq)

root@didiercl:~# journalctl -u dnsmasq
– Logs begin at Mon 2018-07-02 00:44:50 CEST, end at Mon 2018-07-02 11:16:10 CEST. –
juil. 02 10:10:41 didiercl.me systemd[1]: Stopping dnsmasq - A lightweight DHCP and caching DNS server…
juil. 02 10:10:41 didiercl.me dnsmasq[10724]: /etc/resolvconf/update.d/libc: Warning: /etc/resolv.conf is not a symboli
juil. 02 10:10:41 didiercl.me systemd[1]: Stopped dnsmasq - A lightweight DHCP and caching DNS server.
juil. 02 10:10:42 didiercl.me systemd[1]: Starting dnsmasq - A lightweight DHCP and caching DNS server…
juil. 02 10:10:42 didiercl.me dnsmasq[10758]: dnsmasq: syntax check OK.
juil. 02 10:10:42 didiercl.me dnsmasq[10770]: started, version 2.76 cachesize 256
juil. 02 10:10:42 didiercl.me dnsmasq[10770]: compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TF
juil. 02 10:10:42 didiercl.me dnsmasq[10770]: no servers found in /etc/resolv.dnsmasq.conf, will retry
juil. 02 10:10:42 didiercl.me dnsmasq[10770]: read /etc/hosts - 10 addresses
juil. 02 10:10:42 didiercl.me dnsmasq[10771]: /etc/resolvconf/update.d/libc: Warning: /etc/resolv.conf is not a symboli
juil. 02 10:10:42 didiercl.me systemd[1]: Started dnsmasq - A lightweight DHCP and caching DNS server.
juil. 02 11:07:13 didiercl.me systemd[1]: Stopping dnsmasq - A lightweight DHCP and caching DNS server…
juil. 02 11:07:13 didiercl.me dnsmasq[11200]: /etc/resolvconf/update.d/libc: Warning: /etc/resolv.conf is not a symboli
juil. 02 11:07:13 didiercl.me dnsmasq[10770]: exiting on receipt of SIGTERM
juil. 02 11:07:13 didiercl.me systemd[1]: Stopped dnsmasq - A lightweight DHCP and caching DNS server.
juil. 02 11:07:18 didiercl.me systemd[1]: Starting dnsmasq - A lightweight DHCP and caching DNS server…
juil. 02 11:07:18 didiercl.me dnsmasq[11250]: dnsmasq: syntax check OK.
juil. 02 11:07:18 didiercl.me dnsmasq[11261]: started, version 2.76 cachesize 256
juil. 02 11:07:18 didiercl.me dnsmasq[11261]: compile time options: IPv6 GNU-getopt DBus i18n IDN DHCP DHCPv6 no-Lua TF
juil. 02 11:07:18 didiercl.me dnsmasq[11261]: no servers found in /etc/resolv.dnsmasq.conf, will retry
juil. 02 11:07:18 didiercl.me dnsmasq[11261]: read /etc/hosts - 10 addresses
juil. 02 11:07:19 didiercl.me dnsmasq[11262]: /etc/resolvconf/update.d/libc: Warning: /etc/resolv.conf is not a symboli


#10

Bizarre il semble qu’aucun serveur ne soit dans ton fichier
/etc/resolv.dnsmasq.conf

Il faudrait mettre dedans:

nameserver 89.234.141.66


#11

Cela à l’air de fonctionné mais je ne trouve plus mon fichier.cube pour la mise en place du vpn


#12

Bonsoir @ tous,

Tout est résolu merci encore à ljf pour son aide.

Bonne soirée à tous.

didier58


#13

Bonjour,
Depuis un reboot inopiné (coupure de courant), mon serveur n’est plus à l’heure (et ne se met pas à l’heure). Il semble également avoir un problème de résolution de noms de domaines, ce qui expliquerait son soucis pour synchroniser l’heure avec ntp.

Pourtant, j’ai bien des IPs de DNS que mon routeur assigne via DHCP dans /etc/resolv.dnsmasq.conf
Mais les ping retournent toujours “Temporary failure in name resolution”.

Je ne sais plus quoi investiguer… Quelqu’un pour m’aider ?


#14

Essaye ça :

echo "nameserver 9.9.9.9" | sudo tee /etc/resolv.conf
systemctl stop ntp
timeout 20 ntpd -qg &> /dev/null
systemctl start ntp
apt-get update && apt-get install fake-hwclock
rm /etc/resolv.conf

#15

Extra, tout est entré dans l’ordre. Merci beaucoup !

Si tu as le courage, je veux bien comprendre ce qui clochait et comment ces commandes l’ont résolu (pour info, fake-hwclock était déjà installé)…


#16

Ça a créé temporairement un fichier /etc/resolv.conf pour que ta brique utilise comme résolveur DNS l’IP 9.9.9.9, juste le temps nécessaire pour forcer le service ntp à resynchroniser l’horloge et d’installer fake-hwclock.

Ce que je ne comprends pas c’est que tu avais déjà fake-hwclock d’installé. Or c’est le boulot de fake-hwclock de garantir que l’heure soit à peu près correcte après un reboot.
Quand tu disais que ton serveur n’était plus à l’heure c’était à quel point ? Est-ce que l’horloge était réglée sur janvier 1970 ?


#17

La date était bonne et la machine avait ~5 heures de retard (= peut être la durée de la panne de courant ?).

Pour ma culture, quel est le rôle de la commande suivante ?
timeout 20 ntpd -qg &> /dev/null


#18

C’est ça qui force la mise à l’heure de l’horloge (alors qu’en temps normal ntpd ajuste l’heure de façon très lente et progressive).


#19

Encore merci pour le dépannage et les explications !