Database access denied on custom webapp after migration


My YunoHost server

Hardware: VPS bought online
YunoHost version: (stable)
I have access to my server : Through SSH & through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : yes
If yes, please explain: Port changed to 6789
If your request is related to an app, specify its name and version: my_webapp 1.0~ynh14

Description of my issue

I recently moved my server to another provider. I restored all the things, all is well, except the phpBB forum I installed ages ago in a custom webapp (with database). The error is :

SQL ERROR [ mysqli ]

Access denied for user 'my_webapp__2'@'localhost' (using password: YES) [1045]

I checked the values in the db_access.txt file, which is still on my server, and the config.php of phpBB, they’re identical.

So I wonder what’s happening… Can I check the password for user my_webapp__2 in database? It’s encrypted or hashed I guess so I’m not sure I could know. Maybe encrypt/has the same way the password in db_access.txt, to check if the result is the same? Could it work?

Or have I the possibility to change this password?

Thanks a lot!

May I bump this topic?

May I bump this? Still blocked :frowning:

I don’t know if I can easily create a new password for the my_webapp__2 user, if it won’t mess with Yunohost…

Some news: I installed a new “My Webapp”, from scratch. I uploaded my phpBB forum in here and tried to do a fresh install. However, when giving the new username, password and database name, I have the same error:

Could not connect to the database, see error message below.

Access denied for user ‘my_webapp’@‘localhost’ (using password: YES)
[phpBB Debug] “mysqli_real_connect(): (HY000/1045): Access denied for user ‘my_webapp’@‘localhost’ (using password: YES)” in file /var/www/my_webapp/www/phpbb/db/driver/mysqli.php on line 64

I see I’m not alone in this: :slight_smile:

Resolved through the Yunohost Matrix server :slight_smile: (thanks @Aleks , you seem to save me everytime)

The reason was that the password in the settings.yml was different than the db_access.txt one. I used the one in settings.yml (strangely named mysqlpwd and not db_pwd) in the config of my forum, and voila. It works now.

Still don’t know how it happened…

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.