Continuously receiving email about armbian log

,

My YunoHost server

Hardware: Olinuxino Lime2
YunoHost version: 4.2.6.1
I have access to my server : Through SSH | through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance?
Not really.
If yes, please explain:
First installed Armbian encrypted. Then installed Yunohost. Everything in the installation was ok.

Description of my issue

Hi, I installed Yunohost and everything was ok.
I created a new domain and installed Nextcloud on it, and everything works ok.
Then I created a new domain and installed Rainloop on it, it works ok too, but I open the Inbox and discovered it was getting loaded of the same email message which is being received around every 15 minutes.

The subject of the email message is:
Cron root@mydomain /usr/lib/armbian/armbian-truncate-logs

And its body is only one line:
/usr/lib/armbian/armbian-truncate-logs: 18: /etc/default/armbian-ramlog: Syntax error: "(" unexpected

In case it can help, I am pasting below the contents of the file /usr/lib/armbian/armbian-truncate-logs

#!/bin/sh
#
# Copyright (c) Authors: https://www.armbian.com/authors
#
# This file is licensed under the terms of the GNU General Public
# License version 2. This program is licensed "as is" without any
# warranty of any kind, whether express or implied.
#
# truncate, save and clean logs if they get over 75% of the /var/log size
# working only when armbian-ramlog is enabled

treshold=75 # %
JOURNAL_SIZE=5M # size to shrink systemd-journal

[ -f /etc/default/armbian-ramlog ] && . /etc/default/armbian-ramlog

[ "$ENABLED" != true ] && exit 0

logusage=$(df /var/log/ --output=pcent | tail -1 |cut -d "%" -f 1)
if [ $logusage -ge $treshold ]; then
    # write to SD
    /usr/lib/armbian/armbian-ramlog write >/dev/null 2>&1
    # rotate logs on "disk"
    /usr/sbin/logrotate --force /etc/logrotate.conf
    # truncate
    /usr/bin/find /var/log -name '*.log' -or -name '*.xz' -or -name 'lastlog' -or -name 'messages' -or -name 'debug' -or -name 'syslog' | xargs -r truncate --size 0
    /usr/bin/find /var/log -name 'btmp' -or -name 'wtmp' -or -name 'faillog' -or -name 'firewalld' | xargs -r truncate --size 0
    /usr/bin/find /var/log -name 'mail.err' -or -name 'mail.info' -or -name 'mail.warning' | xargs -r truncate --size 0
    # remove
    /usr/bin/find /var/log -name '*.[0-9]' -or -name '*.gz' | xargs -r rm -f
    # vacuum systemd-journald
    [ -d /var/log/journal ] && journalctl --vacuum-size=${JOURNAL_SIZE}
fi

And the contents of the file /etc/default/armbian-ramlog

# configuration values for the armbian-ram-logging service
#
# enable the armbian-ram-logging service?
ENABLED=true
#
# size of the tmpfs mount -- please keep in mind to adjust /etc/default/armbian-zram-config too when increasing
SIZE=50M
#
# use rsync instead of cp -r
# requires rsync installed, may provide better performance
# due to copying only new and changed files
USE_RSYNC=true

# If USE_RSYNC is true, additional options may be specified for the rsync
# commands used to synchronize logs to disk from RAM (XTRA_RSYNC_TO) or from
# disk to RAM (XTRA_RSYNC_FROM).  These are bash arrays to make specifying
# multiple arguments easy even in the presence of whitespace.
XTRA_RSYNC_TO=(
  ## If you use log rotation programs that datestamp their logs (e.g., runit's
  ## svlogd or daemontools' multilog), deleting log files while synchronizing is
  ## likely a good idea.
  # --delete
)
XTRA_RSYNC_FROM=()

Where is the problem and how can I fix it?

Thank you!!

You can try to remove the comments in XTRA_RSYNC_TO var of armbian-ramlog to make it go into XTRA_RSYNC_TO=().

Thanks.

I tried. It makes no difference. I keep receiving exactly the same email message.

Any other suggestion to fix that syntax error?

I’m receiving 96 emails per day.

Or does anyone know how to make the system stop sending that message?

This topic was automatically closed 30 days after the last reply. New replies are no longer allowed.