Continuing errors with an incomplete Bullseye-Migration (mariadb?)

Hi everyone, and a happy new year! :tada:

I’ve had an issue with my yunohost set-up for several months now: My migration to Debian Bullseye went wrong, and ever since I get warnings in my administration interface. During my winter vacation I now wanted to take the time and try addressing it, so I scrolled through forum posts and tried different sorts of things, but unfortunately I wasn’t successful in finding a solution so far. Maybe someone here can help?

My YunoHost server

Hardware: VPS, openvz amd64. running Linux kernel 4.19.0, Debian 11.5
YunoHost version: 11.0.10.2 (stable)
I have access to my server : Through SSH and through the webadmin
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : none that I’m aware of

Description of my issue

For the day-to-day, everything is functioning fine. However, any attempts to update anything or run any migrations fail, also the usual commands such as

sudo apt --fix-broken install
sudo apt clean
sudo dpkg --configure -a
sudo apt autoremove

don’t change anything. (I’ve also tried rebooting the system or restarting multiple times of course). For example, this is the output I get when I run sudo dpkg --configure -a:

mariadb-common (1:10.5.18-0+deb11u1) wird eingerichtet ...
update-alternatives: Fehler: Alternativen-Pfad /etc/mysql/mariadb.cnf existiert                                                                                                   nicht
dpkg: Fehler beim Bearbeiten des Paketes mariadb-common (--configure):
 »installiertes mariadb-common-Skript des Paketes post-installation«-Unterprozes                                                                                                  s gab den Fehlerwert 2 zurück
dpkg: Abhängigkeitsprobleme verhindern Triggerverarbeitung für mariadb-server-10                                                                                                  .5:
 mariadb-server-10.5 hängt ab von mariadb-common (>= 1:10.5.15-0+deb11u1); aber:
  Paket mariadb-common ist noch nicht konfiguriert.

dpkg: Fehler beim Bearbeiten des Paketes mariadb-server-10.5 (--configure):
 Abhängigkeitsprobleme - Trigger bleiben unverarbeitet
Fehler traten auf beim Bearbeiten von:
 mariadb-common
 mariadb-server-10.5

(My apologies it’s in German - if anyone could give me a hint on how to change my server language to English without accidentally breaking things even more than they already are I’d be thankful; I just don’t want to break anything else at the moment).

In short, I believe it all comes back to the faulty migrations, which is why I hope that maybe someone has an idea of how to untangle this half-baked process?

Here are the logs of what happens when I currently try to run the pending migrations: https://paste.yunohost.org/raw/rojexacuqu

And this is the previous migration log mentioned in the error log: https://paste.yunohost.org/raw/qowadakeda

Thank you so much for your consideration, time, and ideas!
Sending you many warm wishes :sun_with_face: