Connexion à metronome/xmpp impossible

Bonjour,

depuis hier et après redémarrage de Yunohost je ne peux plus m’authentifier à xmpp avec le client pidgin. La connexion se fait, pidgin me demande mon mot de passe mais une fois celui-ci rentré (mdp correct) j’ai une erreur d’authentification (Authentication Failure). Le service metronome est actif. J’ai essayé de redémarrer metronome, mais même résultat.

Merci des conseils.

Est-ce que tu as bien un certificat Lets Encrypt valide installé ?

Oui, certificat installé.

Voici les logs :
https://arnauld.org/zerobin/?4c1c9655c5833010#fsDxBOUIK/me2rqqq9VTf1BI8y8vglBfA7GMxTtnkzM=

Si je redémarre Yunohost, metronome ne démarre pas et affiche :

et j’ai ce message d’erreur en haut de la page qui répertorie les services :

Failed to get status information via dbus for service metronome, systemctl didn’t recognize this service (‘NoSuchUnit’).

Cliquer sur le service metronome dans la page où sont listés les services ne fait rien, je ne peux donc pas arrêter ou lancer le service de cette façon.

Et en ligne de commande sudo service metronome restart cela semble lancer metronome puisque le service apparaît “actif” sur la page admin qui liste les services :

Pourtant, Pidgin me répond mauvaise authentification.

J’ai l’impression que ce problème coincide avec les mises à jour proposées et faîtes hier ou avant hier (je ne sais plus).

En effet :confused: J’ai poussé un correctif : https://github.com/YunoHost/yunohost-admin/commit/7322454a8fb362c8d56f717f6ef13e4354f20ef1

bien que ça ne résoud pas le probleme de base : https://github.com/YunoHost/issues/issues/1316

En effet :confused: J’ai poussé un correctif

Et comment appliquer le correctif ?

Il n’y a pas de manière simple sauf à attendre la 3.5 qui arrive bientôt

1 Like

Miracle. Ce matin en allumant mon ordinateur et en me connectant à xmpp via Pidgin, cela fonctionne…