Configuration de ynh-vpnclient (La brique Internet)

Bonjour à tous,

Je suis en train d’installer une brique A20-OLinuXino-LIME en suivant scrupuleusement les instructions de https://yunohost.org/#/installation_brique_fr et http://pad.aquilenet.fr/p/LaBrique

Tout est limpide jusqu’à l’installation du Client VPN. Je rencontre alors 2 problèmes, dont j’ignore s’ils sont liés :

1- Lorsque j’entre mes réglages j’obtiens invariablement le message “Configuration mise à jour mais le rechargement du service a échoué : [ERR] Openvpn is not running”

Si je démarre Openvpn avec

service openvpn start

alors je parviens à obtenir “Configuration mise à jour et service correctement rechargé”

[INFO] Autodetected internet interface: eth0 (last start: eth0)
[INFO] Autodetected IPv6 address for the VPN server: (last start: )
[INFO] IPv6 delegated prefix found
[INFO] IPv6 address computed from the delegated prefix: 2a01:e35:243c:6a90::42
[INFO] Hotspot app detected
[INFO] No IPv6 address to set
[INFO] No native IPv6 detected
[INFO] No IPv6 server route to set
[OK] Openvpn is running

Le client VPN reste toutefois éteint. Si je modifie la configuration quelques minutes plus tard, je reviens à la case départ et Openvpn est stoppé.

2- Mon fournisseur de VPN m’a fourni le fichir ovpn avec les paramètres suivants

 client
 dev tun
 proto udp
 remote mon.vpn.tld 443
 resolv-retry infinite
 nobind
 persist-key
 persist-tun
 remote-cert-tls server
 cipher AES-256-CBC
 comp-lzo no
 route-delay 5
 verb 3
 explicit-exit-notify 5
 ca "ca.crt"
 cert "user.crt"
 key "user.key"
 tls-auth "ta.key" 1

J’ai ajouté user.crt, user.key et le ca par le formulaire, et ajouté manuellement ta.key dans /etc/openvpn/keys. Pour le reste j’ai testé pas mal de choses : garder les options par défaut de ynh-vpnclient, ajouter celles fournies par mon fournisseur de VPN, remplacer uniquement celles qui me paraissaient contradictoires.

Lorsque je me connecte au hotspot, je ne le suis pas via le VPN. A cause du problème #1 assurément, mais je voudrais bien savoir quoi mettre dans la configuration avancée de ynh-vpnclient et j’ai mis ta.key au bon endroit.

Voici l’exposé des faits. Vous aurez deviné : mon niveau de maitrise de la chose est ‘Mr Michu’. Je m’en remets donc à votre expertise et à votre gentillesse pour m’aider à terminer cette installation, mes recherches sur ce forum et dans les tréfonds des Internets ne m’ayant pas débloqué.

Merci de m’avoir lu.

J’essaie d’avancer…

Lorsque ynh-vpnclient est démarré et que je clique sur le bouton Activer dans l’admin, j’ai le message

Impossible d’exécuter la commande ‘update-rc.d ynh-vpnclient defaults’

Quand je tente de lancer cette commande dans un terminal on me dit

initscript does not exist: /etc/init.d/ynh-vpnclient

Est-ce lié à mon problème de configuration (mon post d’origine) ou à un problème d’installation de ynh-vpnclient ?

J’ai effectué une installation fraiche avec le nouvelle image issue du brique camp et j’ai enfin pu me connecter via le VPN de la brique, sans rien faire d’exotique comparé à mes manipulations précédentes.

Merci à tous ceux qui ont travaillé sur cette nouvelle version. Je marque le sujet comme resolu.

Salut,

J’ai le même soucis sur mon raspberry ! Impossible de lancer ynh-vpnclient.

root@raspberrypi:/etc/default# update-rc.d ynh-vpnclient defaults
update-rc.d: using dependency based boot sequencing
update-rc.d: error: unable to read /etc/init.d/ynh-vpnclient

J’aimerais bien comprendre… :smile: