Config Searx coté serveur


#1

Bonjour,

Sauriez vous m’indiquer quels fichiers de conf éditer pour avoir un Searx en français par défaut?
Mon problème est qu’en passant par l’interface web, la conf passe par un cookie, mais ma manière de configurer Firefox ne me permet pas d’enregistrer définitivement le comportement par défaut. Je refuse tous les cookies, ils sont effacés à chaque redémarrage du navigateur.


#2

Bonjour,

J’avais un peu le même problème à un moment. Tu as une solution proposée par cyxae dans ce post.


#3

Ok merci, la syntaxe des fichiers de conf a quelque peu changé et je ne me suis pas méfié, J’ai planté searx. j’ai fait les modifs en dur sans faire de sauvegarde, aurais tu un double du fichier /opt/yunohost/searx/searx/settings.yml à me procurer ? Ça me permettrait de revenir en arrière.

Si je trouve le moyen je mettrai à jour le post de cyxae

Merci.


#4

Bon j’ai désinstallé/réinstallé pour retrouver les conf par défaut.

J’ai tenté une adaptation dans la mesure où il y a des différences, certainement dues à l’évolution du logiciel.

dans /opt/yunohost/searx/searx/settings.yml :slight_smile:

Ça ne se présente pas de la même manière dans la section search:

search:
safe_search : 0 # Filter results. 0: None, 1: Moderate, 2: Strict
autocomplete : "" # Existing autocomplete backends: "dbpedia", "duckduckgo", "google", "startpage", "wikipedia" - leave blank to turn it off by default
default_language : "fr_FR"

j’ai plutôt :

search:
safe_search : 0 # Filter results. 0: None, 1: Moderate, 2: Strict
autocomplete : "" # Existing autocomplete backends: "dbpedia", "duckduckgo", "google", "startpage", "wikipedia" - leave blank to turn it off by default
language : "all"

et si je tente de passer language all -> fr_FR, Searx ne fonctionne plus du tout.


#5

Salut,
Je pense que tu pourrais simplement ajouter une ligne en dessous de.
Language : all
Ta ligne contiendrait juste.
Default language : fr_FR
Si tu n’avais pas déjà testé
Bon courage.


#6

@madmaxlamenace c’est exactement ce que j’ai testé et qui fait planter :frowning:


#7

J’avais fait une modif mais pour ajouter qwant en moteur de recherche activé par défaut.
Ça marchait jusqu’à une mise à jour du paquet. Et je ne l’ai pas re modifié.
Je regarderai de nouveau


#8

Je viens de refaire un essai. Pour la langue de recherche, il faut juste modifier (toujours dans /opt/searx/searx/settings.yml) all par fr à la ligne language ce qui donne :

search:
    safe_search : 0 # Filter results. 0: None, 1: Moderate, 2: Strict
    autocomplete : "" # Existing autocomplete backends: "dbpedia", "duckduckgo", "google", "startpage", "wikipedia" - leave blank to turn it off by default
    language : "fr"

Et pour l’interface par contre ça n’a pas changé, il faut juste ajouter fr dans default_locale :

ui:
    themes_path : "" # Custom ui themes path - leave it blank if you didn't change
    default_theme : oscar # ui theme
    default_locale : "fr" # Default interface locale - leave blank to detect from browser information or use codes from the 'locales' config section

Après un sudo service uwsgi restart pour appliquer les changements, ça marche chez moi.


#9

Ok merci beaucoup ! It works :slight_smile:
Désolé pour le temps de réponse, j’étais loin de chez moi et de mes préoccupations habituelles, quasi déconnecté :slight_smile: (ca fait du bien) .

Dernière chose, je ne connaissais pas uwsgi, une doc en relation avec Yunohost ?


#10

Parfait Searx fait maintenant ses recherches en français, et ça fait du bien, grâce à ta modif ! (avis très personnel !)

Maintenant, je voudrais juste savoir s’il est possible d’activer un/des plugin(s) coté serveur.
Par exemple “infinite scrolling” ou “ouvrir les résultats dans un nouvel onglet” et ce serait parfait de pouvoir les activer par défaut.
J’ai tenté en récupérant leurs petits noms via les cookies, les intégrant un peu au pif dans ce fichier de config, sans succès.
Pas réussi à trouver d’infos à propos de ca dans le wiki :frowning: