Collabora install failed (/etc/loolwsd/ca-chain.cert.pem not found)


My YunoHost server

Hardware: VPS from
YunoHost version: Yunohost (stable) on Debian10 (Kernel: 4.19.0-13-amd64)
I have access to my server : Through SSH & through the webadmin | direct access via keyboard
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no, it’s a clean and fresh install with only Nextcloud installed as well

Description of my issue

After successfully installing Nextcloud on I now tried to also install the Collabora App - YunoHost-Apps/collabora_ynh : (4.0.0~ynh2) on but encountered the same error via WebGUI and CLI, but the first two errors/warnings that stuck out to me:

2021-01-06 09:30:40,414: WARNING - [Error] Jan 06 09:30:39 loolwsd[8401]: wsd-08401-08401 2021-01-06 08:30:39.032314 [ loolwsd ] TRC Pre-read 17 file(s) from directory: /usr/share/loolwsd/loleaflet/dist: branding-tablet.css bundle.css framed.html global.js branding-mobile.css bundle.js admin-bundle.js loleaflet.html device-tablet.css device-desktop.css loleaflet-help.html framed.doc.html device-mobile.css branding.css signing-identities.html branding-desktop.css branding.js | wsd/FileServer.cpp:596

and on when systemd is tryong too run loolwsd service:

2021-01-06 09:30:40,420: WARNING - Jan 06 09:30:39 loolwsd[8401]: File not found: /etc/loolwsd/ca-chain.cert.pem

Links to logs
Logs of install:
journalctl -u loolwsd.service -b hastebin

I assume the former is not the main problem (?), but the latter is causing the trouble with starting up the loolwsd service.
I assume I could try to substitute the ca-chain.cert.pem prior to installation - but with what cert?
I have Let’s encrypt certificates for all my three domains (yunohost/cloud/collabora).

Any help appreciated!

Hmf yeah it’s an annoying bug, I don’t quite understand what/why Collabora want to handle cert stuff and why it just miserably crash.

I see that you opened an issue on the bug tracker - there’s also Failed installation in Ynh 4 · Issue #34 · YunoHost-Apps/collabora_ynh · GitHub which already discuss the issue

(In the meantime the app is flagged level 0 so yunohost should have warned you that it was probably not a good idea to install it)

Anyway, been procrastinating this issue for a while now, maybe will try to have a look after I finish releasing 4.1 …

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.