Collabora dans nextcloud

Bonjour à tous!

Mon serveur YunoHost

Matériel: VM sur serveur dédié OVH
Version de YunoHost: 3.6.5.3
J’ai accès à mon serveur : En SSH | Par la webadmin | En direct avec un clavier/écran
Êtes-vous dans un contexte particulier ou avez-vous effectué des modificiations particulières sur votre instance ? : non

Description du problème

J’essaie de faire fonctionner collabora avec Nextcloud, en vain, j’obtiens toujours le message d’erreur: Hôte WOPI non autorisé. veuillez essayer de nouveau plus tard et en faire part à votre administrateur si le problème persiste.

Le souci c’est que je retrouve beaucoup d’informations contradictoires, je ne sais pas s’il faut utiliser l’application collabora ou collaboradocker.

Sur la liste des applications officielles je ne vois que collabora alors que sur cette page on me parle de collaboradocker: https://yunohost.org/#/collabora

Soit, j’ai essayé le paquet collabora:

  • Ajout du domaine collabora.mondomaine.tld: yunohost domain add collabora.mondomaine.tld
  • Création du certificat: yunohost domain cert-install collabora.mondomaine.tld
  • Installation de collabora: yunohost app install collabora
    ** Domaine: collabora.mondomaine.tld
    ** mot de passe admin: unmotdepassesecret
    ** domaine nextcloud: mondomaine.tld/cloud
  • Installation de l’application “Collabora Online” dans nextloud (accessible à https://mondomaine.tld/cloud)
  • Configuration de l’application “collabora” dans nextcloud dans Paramètres > Administration > Collabora Online Development Edition > URL du serveur collabora : https://collabora.mondomaine.tld

Une fois tout ça fait j’essaie d’ouvrir un fichier ODT, l’interface de collabora commence à se charger puis j’obtiens le message Hôte WOPI non autorisé. veuillez essayer de nouveau plus tard et en faire part à votre administrateur si le problème persiste

J’ai redémarré la machine entre-temps, sans plus de succès.

A noter que j’ai une instance de test de Yunohost installée sur services.mondomaine.tld et que j’avais testé tout ça et que j’avais réussi à le faire fonctionner, j’avais comparé les configurations et il ne me semblait que rien ne différait à part les noms de domaine.

J’ai l’impression qu’il y a une option que j’ai mal configurée mais je ne sais pas quoi. Pouvez-vous m’orienter s’il vous plaît?

Hello,
j’ai exactement le même parcours.
Same experiences, same results.

#metoo moi aussi

je pense le problème vient de la liste des domaine autorisé, normalement l’installation ajoute le domaine nextcloud fournie en argument dans la liste des domaine autorisé a utilisé l’api WOPI

essayer de reinstaller collabora en utilisant juste mondomaine.tld comme domaine nextcloud plutôt que mondomaine.tld/cloud

english version

I think the problem comes from the list of authorized domains, normally the installation add the nextcloud domain provided as argument in the list of authorized domains to used the WOPI API

try to reinstall collabora using just mondomaine.tld as nextcloud domain rather than mondomaine.tld / cloud

Merci c’était bien ça. J’avais essayé de changer le paramètre avec la commande yunohost app setting mais pas la réinstallation.
En revanche autre souci maintenant que collabora s’ouvre bien, impossible d’enregistrer les documents, j’obtiens: Le document ne peut pas être sauvegardé, vérifiez vos permissions ou contactez l'administrateur du service de stockage

Dans les journaux (syslog), ceci apparaît:

Feb 16 09:47:44 services loolwsd[756]: wsd-00756-04965 2020-02-16 08:47:44.328758 [ docbroker_002 ] ERR  Unexpected response to WOPI::PutFile : 500Cannot save file to WOPI storage uri [https://mydomain.tld/cloud/index.php/apps/richdocuments/wopi/files/333_ocqqngioj0kp/contents?access_token=xxxxxxxxxxxxxxxxxxxxxxxx&access_token_ttl=0]. Error: | wsd/Storage.cpp:1109
Feb 16 09:47:44 services loolwsd[756]: wsd-00756-04965 2020-02-16 08:47:44.329249 [ docbroker_002 ] ERR  Failed to save docKey [/cloud/index.php/apps/richdocuments/wopi/files/333_ocqqngioj0kp] to URI [https://mydomain.tld/cloud/index.php/apps/richdocuments/wopi/files/333_ocqqngioj0kp?access_token=xxxxxxxxxxxxxxxxxxxxxxxxxxxx&access_token_ttl=0]. Notifying client.| wsd/DocumentBroker.cpp:1080

J’ai essayé quelques propositions de cette issue Github sans succès https://github.com/nextcloud/richdocuments/issues/781

  • envoyer un document existant puis le modifier
  • désactiver l’application versions

Je n’ai envie d’aller trifouiller dans la base mysql comme une personne l’a suggéré et je suis en version 3.5.2 de l’appli collabora online.

english version

Thanks, you nailed it. I had tried to change the setting with the yunohost app setting command but had not tried reinstalling.
Now there is an other issue, I can’t save my documents with collabora, it says (translated from french) This document can't be saved, check your permissions or contact your storage admin.

This appears in syslog:

Feb 16 09:47:44 services loolwsd[756]: wsd-00756-04965 2020-02-16 08:47:44.328758 [ docbroker_002 ] ERR  Unexpected response to WOPI::PutFile : 500Cannot save file to WOPI storage uri [https://mydomain.tld/cloud/index.php/apps/richdocuments/wopi/files/333_ocqqngioj0kp/contents?access_token=xxxxxxxxxxxxxxxxxxxxxxxx&access_token_ttl=0]. Error: | wsd/Storage.cpp:1109
Feb 16 09:47:44 services loolwsd[756]: wsd-00756-04965 2020-02-16 08:47:44.329249 [ docbroker_002 ] ERR  Failed to save docKey [/cloud/index.php/apps/richdocuments/wopi/files/333_ocqqngioj0kp] to URI [https://mydomain.tld/cloud/index.php/apps/richdocuments/wopi/files/333_ocqqngioj0kp?access_token=xxxxxxxxxxxxxxxxxxxxxxxxxxxx&access_token_ttl=0]. Notifying client.| wsd/DocumentBroker.cpp:1080

I tried some of this Github issue fixes but it still does not work: https://github.com/nextcloud/richdocuments/issues/781

  • send an existing document and modify it with collabora
  • disable the versions application

I don’t want to go into the MySQL database and I am on the 3.5.2 version of the collabora online nextcloud application

@bleeh je voudrait pouvoir t’aider mais je suis malheureusement confronter au même problème depuis la dernière mise a jour de l’application nexcloud collabora , je n’ai pas encore essayer tout les fix proposé mais si j’ai du nouveau de mon coté je te tiendrai informée

Salut Don,
j’avais posé une question dans le fil de discussion sur le Github de l’application Nextcloud, on m’a conseillé d’ouvrir un ticket, je vais plutôt commencer par le github du package déjà, dès que j’aurais un peu de temps pour ça.