Cockpit - Please enable JavaScript to use the Web Console

My YunoHost server

Hardware: Pi 4B
YunoHost version: (stable)
I have access to my server : SSH WEBADMIN
Are you in a special context or did you perform some particular tweaking on your YunoHost instance ? : no
If yes, please explain:
If your request is related to an app, specify its name and version: cockpit 188~ynh2

Description of my issue

Accessing cockpit gives error that javascript is not enabled. But it is.
I have tried setting up a vnc server and accessing it locally, which worked, but it is not optimal since there were some errors, I assume because its meant to be running on a domain and not localhost at some port

I assume it has something to do with the way nginx’s proxy is setup, but I am not a pro at nginx and cannot confirm

There were no logs indicating a error, only logs saying when the webserver started

I get a giant exclamation mark and this text when visiting the cockpit domain. which is - also weird debian logo favicon…

Please enable JavaScript to use the Web Console.


Have the same problem !

Found the solution searching more throughly in the forrum…

It’s here :

1 Like

Thanks @anomp3 that worked for me

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.