[Circumvented :)] Mise à jour de Wordpress : Une autre mise à jour est actuellement en cours

update
#1

Bonjour,

J’ai installé wordPress qui fonctionne bien en dehors du fait que je ne peux pas faire de mise à jour.

J’ai le message
Une autre mise à jour est actuellement en cours.

J’ai vu quelques messages sur un pb de ce genre et fail2ban en serait la cause.
J’ai désactivé puis supprimé fail2ban
Toujours le même problème.

J’ai lancé la mise à jour des apps à partir de l’écran d’admin de YNH,
Je reçois le compte-rendu :

" ```
2019-06-08 15:54:40,970 SUCCESS yunohost.app success - [911.415] wordpress is already up to date
2019-06-08 15:54:41,119 SUCCESS yunohost.app success - [911.415] The SSOwat configuration has been generated
2019-06-08 15:54:41,120 SUCCESS yunohost.app success - [911.415] Upgrade complete
2019-06-08 15:54:41,146 SUCCESS yunohost.tools success - [911.415] The system has been upgraded


En fait non, la dernière version de WP n'est pas installée et j'ai toujours le même message d'erreur ci-dessus.

Merci pour toutes pistes ou une solution.

Tiens, c'est en rouge après l'apostrophe :)

Amicalement, José
#2

Bonjour,
Peut être le même problème ?

#3

YunoHost is telling you here that Wordpress is already up to date.
Your package is probably up to date.
If you’re looking for Wordpress itself, it handle its update on its own. You should receive an email anytime soon from your server to tell you that wordpress has done its upgrade.

#4

Thank you for your feedback.
Hi @Maniack_Crudelis, currently we have 5.2 WP version and now we have the 5.2.1 version.
WP proposes to install this update. When I run this update, I’ve got this message.

I wonder if WP is autonomous from YNH or if we are obliged to wait for the update from YNH app?

Bonjour @anonyme18, j’ai lu ce post… un peu compliqué et je ne suis pas sûr que cela soit le même pb. J’ai supprimer fail2ban… même pb !
Je me demande si WP est autonome ou si il faut attendre la mise à jour… YNH.


Now I got a new message:

"Mettre à jour WordPress
Téléchargement de la mise à jour depuis https://downloads.wordpress.org/release/fr_FR/wordpress-5.2.1.zip…

L’authenticité de wordpress-5.2.1.zip n’a pas pu être vérifiée car aucune signature n’a été trouvée.

Décompression de la mise à jour…

Le site rencontre des difficultés techniques. Veuillez relever la boîte de messagerie du compte administrateur du site pour obtenir des instructions."

Roughly… WP 5.2.1 zip authenticity cannot be verified, any signature has been found.

I am going to contact the WP app team.

Thank you for your time.

Best regard | Amicalement, José from France.

#5

Hum…
Hi @Maniack_Crudelis
About my issue, I noted this in App categorie…

So, I understand when you install WP with YNH, you are in 5.2.
Do we are obliged to wait for an YNH app 5.2.1 upgrade?

And "Force auto upgrade with a cron"
what is it?

Thank you for your time and consideration.

BR, José from France.

#6

Since the last upgrade, a cron job reach your wordpress at least once a day to trig the auto-updating plugin.
That means only that the plugin used to automatically upgrade your wordpress should better work now. Especially if your blog was private or not often visited.

Upgrade for this package does not upgrade the app itself. Because wordpress do update itself from its admin panel, it would be dangerous to force a version of wordpress during the upgrade. So, this package let wordpress managed its own upgrade.

I did upgrade my own wordpress right now, no problem with the upgrade to 5.2.1
Maybe try to let wordpress do the upgrade on its own.

#7

Hi @Maniack_Crudelis
Thank you for this clear and comprehensive feedback.

So, I have to focus on this message

“WP-5.2.1.zip authenticity could not be checked because any signature has been found”

I am on a OVH VPS.
Let me see if it is easy to update WP manually with the zip file.

#8

That looks like an error from wordpress servers.
You should retry later and see if it works.

I failed yesterday evening to upgrade manually some plugins on one of my wordpress, because of a similar error. It worked this morning.

#9

Hi @Maniack_Crudelis

I try this morning (10:09)… It did not work :frowning:
From this server: https://downloads.wordpress.org/release/fr_FR/wordpress-5.2.1.zip

I contact WP… to have more information :wink:

#10

Hi @Maniack_Crudelis ,

I downloaded a new WP in US…
Update works perfectly… I am in 5.2.1 :slight_smile:

Please, note I receive this message from WP :slight_smile: :

Please update your site at https://bacasable.eu/page to WordPress 5.2.1.

We tried but were unable to update your site automatically. Updating is easy and only takes a few moments:
https://bacasable.eu/page/wp-admin/update-core.php

By the way,
I noted the fail2ban plugin presence, I imagine it has been set by WP.
I think we do not need this plugin as we have YNH fail2ban.

Thank you for your time and consideration.
José from France

#11

Hi,

Now it is very clear…

You can update to 5.2.1 with the US-En language package, not with the French language package!
At least, regarding my configuration (VPS chez OVH)

I continue with an US-En package :slight_smile:

I note this thread as “Circumvented” :slight_smile:

Thank you for your help.

Best Regards from France, José

#12

Ok, that’s strange, I guess the French server has issues.
That’s a good idea you had to inform WordPress that you had this issue, hope they’ll find and fix something.

Fail2ban plugin is added by the YNH wordpress package. Without the plugin, wordpress won’t log failed logins, so Fail2ban can’t work.

#13

HI

The post: https://wordpress.org/support/topic/5-2-1-update-ok-with-en-us-langage-not-french

About Fail2ban WP plugin, I understand I have to let it activated :).

Thank you for your time and consideration @Maniack_Crudelis