Choix forum en fonction des capacités d'un VPS

Bonjour,
Sur une offre VPS SSD1 d’OVH, j’ai un VPS avec

  • 2 Go de RAM
  • 20 de disque SSD
    J’ai un serveur de mail, un repertoire web et un Wordpress d’installés

J’aimerais installéer un forum de discussion. Parmi ceux proposés par yonohost, lequel correspondrait à ce VPS ?
Le forum serait peu fréquenté avec peu d’utilisateurs (plus un groupe local de discussion) ?

Si possible j’aimerais héberger les pièces jointes sur un autre espace disque afin d’allèger mon VPS (connaissez vous des services de ce style ? )

(version yunohost : la stable, à jour)

D’avance merci,

Salut ! je dirais n’importe lequel. Avec 2Go de RAM, tu peux mettre après tout n’importe lequel. Discourse est très lourd (https://github.com/YunoHost-Apps/discourse_ynh). Il possède peut-être trop pour ton usage, mais s’il te plaît ça peut largement convenir. Par contre, si tu le choisis, dis-toi que les autres services seront ralentis (il est assez gourmand).

Sinon, flarum est super et très bien maintenu par @TitusPiJean. Il est assez léger et très beau. (https://github.com/YunoHost-Apps/flarum_ynh). Il me semble plus adapté à l’usage que tu veux en faire.

Pour ce qui est des pièces jointes… je ne sais pas trop, mais il faudrait voir dans le doc de discourse ou flarum (ou même demander sur leur forum respectif) quels sont les modules et applications externses qui sont supportés. Pour la plupart tu pourras normalement indiqué un répertoire spécifique. Si cet espace de stockage est attaché à ton VPS tu n’auras plus qu’à le monter et indiqué le nom du répertoire à ce moment-là.

1 Like

Impecc. merci beaucoup pour cette réponse , je vais tester flarum et je verrais ensuite pour les PJ, au pire je prendrai un autre VPS mais chez contab et m’en servirai (https://contabo.com/?show=vps) comme espace de stockage
Bonne soirée

1 Like

Flatteur, va. :stuck_out_tongue_closed_eyes:


@crustyourmind, Flarum a une extension, Flagrow upload, toute faite pour stocker des fichiers sur d’autres services. :wink: Et je crois que tu peux toujours faire un lien symbolique du dossier assets dans un autre espace de stockage (non testé).

2 Likes

C’est pas flatteur. :smiley: Tu vois, je te pingue il y a 14 minutes et tu es déjà là. :wink: (c’est vrai que la quote pris comme ça… ça fait étrange :joy:)

Si tu as d’autres question en tout cas, n’hésite pas. :wink:

1 Like

OK C’est noté mais pour l’instant, y’a plus qu’à tester
thanx a lot !!

1 Like

J’ai installé flarum, c’est vrai que ce n’est pas mal du tout
Par contre je suis emnbeté pour installer l’extension sus citée

J’ai installé composer

puis

# composer require flagrow/upload
Do not run Composer as root/super user! See https://getcomposer.org/root for details

je le fais donc en user , mais

$  composer require flagrow/upload
./composer.json is not writable.

une aide, c’est la première que j’utilise cette fonctionnalité (composer) ?

OK je pense avoir trouvé la solution dans la doc de bazaar

Make sure that the following directories and files are writable by the web/php user:

composer.json
composer.lock
vendor/

Sous yunohost, je le fais donc sous quel compte ?

Bonjour,
J’ai peur de dire une bétise, c’est peut-être un utilisateur dédié Flarum, sinon, je tenterai
www-data !

Bon, j’ai changé les droits et ai donné les droits à admin vua que c’est lui qui a ce fichier dans son /home
Par contre, l’installation plante

  Problem 1
    - Installation request for flagrow/upload ^0.7.1 -> satisfiable by flagrow/upload[0.7.1].
    - flagrow/upload 0.7.1 requires flarum/core ^0.1.0-beta.8 -> satisfiable by flarum/core[0.1.x-dev, v0.1.0-beta.10, v0.1.0-beta.11, v0.1.0-beta.11.1, v0.1.0-beta.8, v0.1.0-beta.8.1, v0.1.0-beta.8.2, v0.1.0-beta.9] but these conflict with your requirements or minimum-stability.

Ne voulant pas planter mon serveur, je vais essayer d’autres pistes pour l’upload d’images…

Oups j’écris n’importe quoi, ça ne passait pas car je n’étais pas dans le répertoire root de flarum…
Ane que je suis…

Par contre, maintenant c’est ma version php qui fait des siennes

Problem 1
- doctrine/cache 1.10.0 requires php ~7.1 -> your PHP version (7.0.33) does not satisfy that requirement.
- doctrine/cache 1.10.0 requires php ~7.1 -> your PHP version (7.0.33) does not satisfy that requirement.
- doctrine/cache 1.10.0 requires php ~7.1 -> your PHP version (7.0.33) does not satisfy that requirement.
- Installation request for doctrine/cache (locked at 1.10.0) -> satisfiable by doctrine/cache[1.10.0].

Salut,

Tu as la procédure pour installer des extensions ici. :wink:

Il est possible que flagrow/upload ne soit pas encore à jour pour la beta 12 de Flarum.

Ensuite, ça serait sympa d’aller sur le topic dédié à Flarum ou d’en créer un nouveau pour ne pas dévier du sujet initial du topic.
Merci ! :wink: